configuring UART3 on sabresd IMX6Q board.

cancel
Showing results for 
Search instead for 
Did you mean: 

configuring UART3 on sabresd IMX6Q board.

316 Views
muhammadawais
Contributor I

Hello,

I am trying to use uart3 on sabresd board from the GPS pads present on the boards. My board doesn't have a GPS module installed so I have soldered wires of RX TX on the board.
I put following configuration in the imx6qdl-sabresd.dtsi file and the loopback testing using echo/cat  works Perfect.
pinctrl_uart3: uart3grp {
           fsl,pins = <
            MX6QDL_PAD_EIM_D25__UART3_RX_DATA 0x1b0b1                              
            MX6QDL_PAD_EIM_D24__UART3_TX_DATA 0x1b0b1          
           >;
          };

&uart3 {
      pinctrl-names = "default";
      pinctrl-0 = <&pinctrl_uart3>;
     status = "okay";
};


But I want to use hardware flow control and when I put the following configurations the UART3 doesn't work. No response of loopback is received.


 pinctrl_uart3_1: uart3grp-1 {
           fsl,pins = <
            MX6QDL_PAD_EIM_D25__UART3_RX_DATA 0x1b0b1                              
            MX6QDL_PAD_EIM_D24__UART3_TX_DATA 0x1b0b1            
                    MX6QDL_PAD_EIM_D23__UART3_CTS_B   0x1b0b1
            MX6QDL_PAD_EIM_D31__UART3_RTS_B   0x1b0b1
           
           >;
          };
         pinctrl_uart3dte_1: uart3dtegrp-1 {
           fsl,pins = <
            MX6QDL_PAD_EIM_D25__UART3_TX_DATA 0x1b0b1    
            MX6QDL_PAD_EIM_D24__UART3_RX_DATA 0x1b0b1    
                    MX6QDL_PAD_EIM_D31__UART3_CTS_B   0x1b0b1
            MX6QDL_PAD_EIM_D23__UART3_RTS_B   0x1b0b1
           
           >;
          };

&uart3 {
 pinctrl-names = "default";
 pinctrl-0 = <&pinctrl_uart3_1>;
 fsl,uart-has-rtscts;
 status = "okay";
};

Please help me with the problem . Thanks@

Tags (4)
0 Kudos
3 Replies

133 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi muhammad

one can check if flow signals direction is correct using

Table 86. UART I/O Configuration vs. Mode i.MX6DQ Datasheet

http://www.nxp.com/docs/en/data-sheet/IMX6DQCEC.pdf

and verify operation with baremetal test Github SDK
https://github.com/backenklee/swp-report/tree/master/iMX6_Platform_SDK   

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

133 Views
muhammadawais
Contributor I

Hi Igor,

I have got it working. I figured out the problem was with MX6QDL_PAD_EIM_D23_ was already being used for other device. (imx6qdl-sabresd { pinctrl_hog: hoggrp ).

I removed it from there and the UART3 works perfect now. Thank you so much for your time and help.


Best Regards,

Muhammad Awais

0 Kudos

133 Views
muhammadawais
Contributor I

Hi Igor,

thanks for your reply, I have tested it with different direction setting but it isn't working. Actually I guess the direction doesn't matter for now as I haven't connected with any other device. I am just checking the loopback.(shorting RX/TX CTS/RTS with each other). So regardless of the direction settings it should respond?

Best Regards,

Muhammad Awais.

0 Kudos