can not build gstreamer1.0-rtsp-server on NXP i.MX 8MMini EVK (imx8mmevk)

cancel
Showing results for 
Search instead for 
Did you mean: 

can not build gstreamer1.0-rtsp-server on NXP i.MX 8MMini EVK (imx8mmevk)

642 Views
wlxl_1204
Contributor I

hi ,

I follow the newest release imx-yocto-L4.14.98_2.0.0_ga and the doc i.MX_Linux_User's_Guide.pdf to bulid gstreamer1.0-rtsp-server.

1. Enable the layer meta-openembedded/meta-multimedia:
Add the line BBLAYERS += "${BSPDIR}/sources/meta-openembedded/meta-multimedia" to the
configuration file $yocto_root/build/conf/bblayers.conf.
2. Include gst-rtsp-server into the image build:
Add the line IMAGE_INSTALL_append += "gstreamer1.0-rtsp-server" to the configuration file
$yocto_root/build/conf/local.conf.
3. Run bitbake for your image to build with gst-rstp-server.

I run build with bitbake -k core-image-minimal

but can not find :

$yocto_root/build/tmp/work/cortexa9hf-vfp-neon-poky-linux-gnueabi/gstreamer1.0-rtsp-server/$version/build/
examples/.libs

nothing can be found except for the Makfile:

ls   $yocto_root/build/tmp/work/aarch64-poky-linux/gstreamer1.0-rtsp-server/1.14.4-r0/build/examples   -a

.  ..  Makefile

when I run  bitbake gstreamer1.0-rtsp-server, the same can not found .libs.

what issues I made? can anyone help me? thanks.

0 Kudos
2 Replies

405 Views
radhikasomaiya
Senior Contributor II

Hi wlxl_1204@163.com ,

To build .libs/test-uri (to build examples and tests) remove or comment the below line from file gstreamer1.0-rtsp-server.inc (path: sources/poky/meta/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server.inc).

 

         EXTRA_OECONF = "--disable-examples --disable-tests"

 

then follow the steps from section 7.3.14 RTSP streaming server of i.MX Linux User's guide.

 

Let us know if you have any further query.

 

Regards,

Radhika Somaiya.

0 Kudos

406 Views
joanxie
NXP TechSupport
NXP TechSupport

Add the line IMAGE_INSTALL_append += "gstreamer1.0-rtsp-server" to the configuration file
$yocto_root/build/conf/local.conf. you need add this to the local.conf, then bitbake it

0 Kudos