blow fuse on imx25

cancel
Showing results for 
Search instead for 
Did you mean: 

blow fuse on imx25

Jump to solution
586 Views
leonardoalmeida
Contributor I

Hello all.

I'm trying to blow fuses using ATK MAX, version 1.7.1. The same error happens if FUSE_VDD is 0 or 1. The image attached contains the error image.

I'm using imx25_3stack board.

I appreciate your help.

Labels (1)
Tags (2)
0 Kudos
1 Solution
203 Views
bfac
NXP Employee
NXP Employee

Team, thanks for the help,

I would like to update everyone with the solution to this topic.

The newest version of ATK 1.7.1 does not work for fuse blow on iMX25 for an unidentified reason.

We downgraded to 1.6.8 and could now successfully blow the fuses.

Tip provided by @Yuri_Muhin .

Best regards,

Bruno

View solution in original post

0 Kudos
6 Replies
204 Views
bfac
NXP Employee
NXP Employee

Team, thanks for the help,

I would like to update everyone with the solution to this topic.

The newest version of ATK 1.7.1 does not work for fuse blow on iMX25 for an unidentified reason.

We downgraded to 1.6.8 and could now successfully blow the fuses.

Tip provided by @Yuri_Muhin .

Best regards,

Bruno

View solution in original post

0 Kudos
203 Views
leonardoalmeida
Contributor I

I'd like to thank everybody for the help.

Best regards,

Leonardo

0 Kudos
203 Views
bfac
NXP Employee
NXP Employee

Thanks Jimmy,

I just talked with Leonardo, please notice that with this same board, with the Vdd_fuse powered on, we could program a test fuse using u-boot, so we know our hardware is ok.

The 2 problems with that are: this method is "blind" so I don't have a clear way of understanding what is done and what is not. We need a way to do this program in production line, the ATK should solve that.

We still have 2 main issues:

1) With ATK, we cannot program or read the fuses, see the error message above. We did this test in the same board, with the same Vdd_fuse applied, with no success. Can you help us understanding why ATK is not working?

2) We need to understand how to use the shadow-register test feature, what we need is a way to test the fuse-program once, before actually blowing the fuses, so we don't lose any boards (we only have a couple of prototypes). On a first study, we thought this would be accomplished by having GND on the Vdd_fuse, trying to program the fuses, and then doing a soft reset. But it didnt work.

Thanks!

0 Kudos
203 Views
bfac
NXP Employee
NXP Employee

Another important comment:

The ATK is working fine with that exact board and configuration, we can say this as we are able to successfully program a flash memory on the device using the ATK over USB. But when, in the same session, we try to read or write on fuses, the error message attached shows up.

Thanks!

Bruno

0 Kudos
203 Views
jimmychan
NXP TechSupport
NXP TechSupport

Please make sure the Fusebox program supply voltage is 3.6V.

For your information: http://cache.freescale.com/files/dsp/doc/app_note/AN3682.pdf

0 Kudos
203 Views
leonardoalmeida
Contributor I

Hi, Jimmy.

First of all, thanks for answering. I'd like to give some extra details and sumarize the problem:

- With FUSE_VDD in VCC: The iim driver from u-boot blows and reads fuses successfully. From ATK, it reads the "default fuse library", but it doesn't read/sense any fuse.

- With FUSE_VDD in GND: From ATK, the same error occurs. The iim driver from u-boot doesn't blow the fuses, but it reads always as unblown even before software reset. The reading is also done by iim driver, which follows the section 30.4.5.1 - Read Sequence from datasheet.

I'd like to simulate it with shadow fuses or to have the ATK working for diagnostics before blowing fuses.

Thanks!

0 Kudos