Yocto for IMX6 Sabersd

cancel
Showing results for 
Search instead for 
Did you mean: 

Yocto for IMX6 Sabersd

Jump to solution
390 Views
Contributor IV

Hi,

I am trying to build images for IMX6Q-SDB board using Yocto.

I have followed below steps.

#mkdir ~/bin

#curl http://commondatastorage.googleapis.com/git-repo-downloads/repo > ~/bin/repo

The above curl command failed so downloaded repo from brpwser and saved to ~/bin.

#chmod a+x ~/bin/repo

#export PATH=~/bin:$PATH

#mkdir fsl-release-bsp

#cd fsl-release-bsp

#git config --global user.name "Your Name"

#git config --global user.email "Your Email"

#git config --list

#repo init -u git://git.freescale.com/imx/fsl-arm-yocto-bsp.git -b imx-3.10.53-1.1.0_ga

The repo init command failed while trying to access "https://gerrit.googlesource.com/git-repo/info/refs"

Get https://gerrit.googlesource.com/git-repo/clone.bundle

Get https://gerrit.googlesource.com/git-repo

error: Failed connect to gerrit.googlesource.com:8002; Connection timed out while accessing https://gerrit.googlesource.com/git-repo/info/refs

fatal: HTTP request failed

I tried to access "https://gerrit.googlesource.com/git-repo/info/refs" through browser then it is giving page not found error.

I have tried with repo from "http://commondatastorage.googleapis.com/git-repo-downloads/repo", but still same error.

Can you please guide me whether the repo I am using is proper or not.

Labels (2)
0 Kudos
1 Solution
15 Views
Contributor IV

The issue is with the proxy. In office networy we are using proxy, after disabling proxy using "unset http_proxy" it is working fine.

We can disable proxy in /etc/environment also.

After repo init command repo sync also succeeded.

#repo init -u git://git.freescale.com/imx/fsl-arm-yocto-bsp.git -b imx-3.10.53-1.1.0_ga

#repo sync

Following commands are used to build images using yocto for IMX6 Sabersd.

#source setup-environment build

#bitbake core-image-minimal

View solution in original post

0 Kudos
1 Reply
16 Views
Contributor IV

The issue is with the proxy. In office networy we are using proxy, after disabling proxy using "unset http_proxy" it is working fine.

We can disable proxy in /etc/environment also.

After repo init command repo sync also succeeded.

#repo init -u git://git.freescale.com/imx/fsl-arm-yocto-bsp.git -b imx-3.10.53-1.1.0_ga

#repo sync

Following commands are used to build images using yocto for IMX6 Sabersd.

#source setup-environment build

#bitbake core-image-minimal

View solution in original post

0 Kudos