Yocto compile fail for machine "cubox-i", recipe kernel-module-imx-gpu-viv

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Yocto compile fail for machine "cubox-i", recipe kernel-module-imx-gpu-viv

1,636 Views
jamescurran
Contributor II

Hello I am using yocto to build a distribution for the hummingboard (machine cubox-I). I am using Morty versions of freescale layers as follows:

Build Configuration:
BB_VERSION        = "1.32.0"
BUILD_SYS         = "x86_64-linux"
NATIVELSBSTRING   = "universal-4.8"
TARGET_SYS        = "arm-poky-linux-gnueabi"
MACHINE           = "cubox-i"
DISTRO            = "poky"
DISTRO_VERSION    = "2.2.1"
TUNE_FEATURES     = "arm armv7a vfp thumb neon       callconvention-hard       cortexa9"
TARGET_FPU        = "hard"
meta             
meta-poky        
meta-yocto-bsp    = "heads/origin/morty:924e576b8930fd2268d85f0b151e5f68a3c2afce"
meta-freescale    = "morty:fc804d29ee85d58e9bb66f7319e749b53e192457"
meta-freescale-3rdparty = "morty:d31308389508945bd4432a6f0213c27eacf6a1b8"
meta-mono         = "morty:b8e5da7138c61fb9ade87712a2fc28dc6283ab25"
meta-webserver   
meta-networking  
meta-python      
meta-oe           = "morty:fe5c83312de11e80b85680ef237f8acb04b4b26e"
meta-cwlayer      = "heads/origin/morty:924e576b8930fd2268d85f0b151e5f68a3c2afce"
meta-swupdate     = "krogoth:712d4aee92ea3a23952a3e7fb812e5c4df7492ec"

 

However I get a compile error:

ERROR: Task (/home/james/poky/meta-freescale/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p8.6+fslc.bb:do_compile) failed with exit code '1'

Here is a snippet from the fail log:

/home/james/poky/build/tmp/work/cubox_i-poky-linux-gnueabi/kernel-module-imx-gpu-viv/5.0.11.p8.6+fslc+gitAUTOINC+a05d9b23b9-r0/git/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/gc_hal_kernel_linux.h:121:65: note: each undeclared identifier is reported only once for each function it appears in
 #define GetPageCount(size, offset)     ((((size) + ((offset) & ~PAGE_CACHE_MASK)) + PAGE_CACHE_SIZE - 1) >> PAGE_CACHE_SHIFT)
                                                                 ^
/home/james/poky/build/tmp/work/cubox_i-poky-linux-gnueabi/kernel-module-imx-gpu-viv/5.0.11.p8.6+fslc+gitAUTOINC+a05d9b23b9-r0/git/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/gc_hal_kernel_os.c:1602:16: note: in expansion of macro 'GetPageCount'
     numPages = GetPageCount(bytes, 0);
                ^~~~~~~~~~~~
/home/james/poky/build/tmp/work/cubox_i-poky-linux-gnueabi/kernel-module-imx-gpu-viv/5.0.11.p8.6+fslc+gitAUTOINC+a05d9b23b9-r0/git/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/gc_hal_kernel_linux.h:121:85: error: 'PAGE_CACHE_SIZE' undeclared (first use in this function)
 #define GetPageCount(size, offset)     ((((size) + ((offset) & ~PAGE_CACHE_MASK)) + PAGE_CACHE_SIZE - 1) >> PAGE_CACHE_SHIFT)
                                                                                     ^
/home/james/poky/build/tmp/work/cubox_i-poky-linux-gnueabi/kernel-module-imx-gpu-viv/5.0.11.p8.6+fslc+gitAUTOINC+a05d9b23b9-r0/git/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/gc_hal_kernel_os.c:1602:16: note: in expansion of macro 'GetPageCount'
     numPages = GetPageCount(bytes, 0);
                ^~~~~~~~~~~~
/home/james/poky/build/tmp/work/cubox_i-poky-linux-gnueabi/kernel-module-imx-gpu-viv/5.0.11.p8.6+fslc+gitAUTOINC+a05d9b23b9-r0/git/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/gc_hal_kernel_linux.h:121:109: error: 'PAGE_CACHE_SHIFT' undeclared (first use in this function)
 #define GetPageCount(size, offset)     ((((size) + ((offset) & ~PAGE_CACHE_MASK)) + PAGE_CACHE_SIZE - 1) >> PAGE_CACHE_SHIFT)
                                                                                                             ^
/home/james/poky/build/tmp/work/cubox_i-poky-linux-gnueabi/kernel-module-imx-gpu-viv/5.0.11.p8.6+fslc+gitAUTOINC+a05d9b23b9-r0/git/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/

Any idea how I can fix this?

5 Replies

1,084 Views
pastrana
Contributor III

Hi,

I have this problem too.

Any solution?

Regards,

Javi

0 Kudos

1,084 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello James Curran,

I haven’t tested these images but which image are you trying to build? It could be related to the licenses required to use the Vivante GPU driver.

There is some information on the Solid-Run forums. I’ll let you know if I find something on how to fix this.

Regards,

0 Kudos

1,084 Views
jamescurran
Contributor II

Hello gusarambula,

I am building core-image-minimal. I will look at solidrun website I have contacted them but they have not replied yet.

Regards,

James Curran

Firmware engineer

Curtiss-Wright

T: +353.1.437.5621 | F: +353.1.295.1265

jpcurran@curtisswright.com<mailto:jpcurran@curtisswright.com> | www.cwc-ae.com<http://www.cwc-ae.com/>;

0 Kudos

1,084 Views
refiktuzaklı
Contributor III

Hi,

Could you find the solution? I have also faced with it.

regards

0 Kudos

1,084 Views
jamescurran
Contributor II

Hello,

No I did not. I am now trying to get support from solid run for the hummingboard build.

I will forward you the email they sent, but still does not work.

James Curran

Firmware engineer

Curtiss-Wright

T: +353.1.437.5621 | F: +353.1.295.1265

jpcurran@curtisswright.com<mailto:jpcurran@curtisswright.com> | www.cwc-ae.com<http://www.cwc-ae.com/>;

0 Kudos