Yocto Rocko QT5 toolchain build failure

cancel
Showing results for 
Search instead for 
Did you mean: 

Yocto Rocko QT5 toolchain build failure

1,771 Views
coindu
Contributor IV

HI,

      After build wayland success and attempt to obtain the QT5 toolchain , an error occurred. The compilation process is as follows

       repo init -u https://source.codeaurora.org/external/imx/imx-manifest -b imx-linux-rocko -m imx-4.9.88-2.0.0_ga.xml

         repo sync

          DISTRO=fsl-imx-wayland MACHINE=imx8mqevk source fsl-setup-release.sh -b build-wayland

          bitbake fsl-image-qt5-validation-imx

         

          after build success

          . ./setup-environment build-wayland

         bitbake meta-toolchain-qt5

------------------------------------------------------------------------------------------------

         

Error: Transaction check error:
file /opt/fsl-imx-wayland/4.9.88-2.0.0/sysroots/x86_64-pokysdk-linux/environment-setup.d conflicts between attempted installs of nativesdk-cmake-3.8.2-r0.x86_64_nativesdk and nativesdk-qtbase-tools-5.9.4+git0+0d9208cecb-r0.x86_64_nativesdk

Error Summary
-------------


ERROR: meta-toolchain-qt5-1.0-r0 do_populate_sdk: Function failed: do_populate_sdk
ERROR: Logfile of failure stored in: /home/duxy/imx-yocto-bsp/build-wayland/tmp/work/aarch64-poky-linux/meta-toolchain-qt5/1.0-r0/temp/log.do_populate_sdk.488
ERROR: Task (/home/duxy/imx-yocto-bsp/sources/meta-qt5/recipes-qt/meta/meta-to

please tell me how to solve this question.

0 Kudos
3 Replies

532 Views
catia_han
NXP Employee
NXP Employee

Hi coin,

   Has this problem been solved? I met the same problem , and I  modified one line content in the ../sources/meta-qt5/recipes-qt/qt5/nativesdk-qtbase_git.bb  file. This line modified like below:

  

 fakeroot do_generate_qt_environment_file() { -    mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d/ +    install -d -m 755 ${D}${SDKPATHNATIVE}/environment-setup.d/      script=${D}${SDKPATHNATIVE}/environment-setup.d/qt5.sh        echo 'export PATH=${OE_QMAKE_PATH_HOST_BINS}:$PATH' > $script
 After modified,you can re-run $bitbake meta-toolchain-qt5,then the problem can be solved.

Best Regard

Catia Han

0 Kudos

532 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hi coin,

This is weird, apparently you have other yocto downloaded in the same directory, however please try to downloaded again.

Regard

0 Kudos

251 Views
Rohit_B
Contributor I

Observed same issue with Rocko .

Is this resolved ?

Error: Transaction check error:
file /opt/fsl-imx-x11/4.9.88-2.0.0/sysroots/x86_64-pokysdk-linux/environment-setup.d conflicts between attempted installs of nativesdk-cmake-3.8.2-r0.x86_64_nativesdk and nativesdk-qtbase-tools-5.9.4+git0+0d9208cecb-r0.x86_64_nativesdk

0 Kudos