Yocto Linux L4.9.51 for i.MX 8MQuad GA release: imx-gpu-viv_6.2.4.p1.0 is broken for non-Wayland build configurations

cancel
Showing results for 
Search instead for 
Did you mean: 

Yocto Linux L4.9.51 for i.MX 8MQuad GA release: imx-gpu-viv_6.2.4.p1.0 is broken for non-Wayland build configurations

1,875 Views
sergei_p
Contributor III

Hello,

I'm building the fsl-image-qt5-validation-imx image using 4.9.51 for i.MX 8MQuad GA release. My build is configured as below:

$ DISTRO=fsl-imx-fb MACHINE=imx8mqevk source fsl-setup-release.sh -b build-20180329

The build fails in building the cairo package. The reason of the failure is that the pre-built shared library from the imx-gpu-viv_6.2.4.p1.0 package contains reference to the Wayland library:

psl@i7 build-20180329]$ readelf -d tmp/sysroots/imx8mqevk/usr/lib/gbm_viv.so

Dynamic section at offset 0x2888 contains 28 entries:
Tag Type Name/Value
0x0000000000000001 (NEEDED) Shared library: [libdrm.so.2]
0x0000000000000001 (NEEDED) Shared library: [libGAL.so]
0x0000000000000001 (NEEDED) Shared library: [libwayland-server.so.0]
0x0000000000000001 (NEEDED) Shared library: [libc.so.6]
0x000000000000000e (SONAME) Library soname: [gbm_viv.so]
0x000000000000000c (INIT) 0x1170
...

Please advice.

Regards,

Sergei

Labels (1)
9 Replies

344 Views
joanxie
NXP TechSupport
NXP TechSupport

As I known, imx8m only supports wayland, so try to use the command as below, any error message, pls tell me

$ DISTRO=fsl-imx-xwayland MACHINE=imx8mqevk source fsl-setup-release.sh –b build-xwayland

$ DISTRO=fsl-imx-wayland MACHINE=imx8mqevk source fsl-setup-release.sh -b build-wayland

0 Kudos

344 Views
kendalla59
Contributor I

So to be explicitly clear, I must only use DISTRO=fsl-imx-wayland for MACHINE=imx8mqevk. Yes?

May I assume that some time in the future, the bsp will support X11? Is there an estimate for the release of this support?

For me personally, I will never be critical of a support engineer being verbose or redundant when answering questions. Very short and cryptic answers however make searching for solutions more difficult.

Thank you!

0 Kudos

344 Views
zyend
Contributor II

Hello Kendall,

I'm also in the same situation.

I must evaluate our new IMX8 board, and though I'm noob with imx boards, I understand that the IMX8 community layers are not availables yet.

So if I have understood your previous posts, the current official BSP does not support the fsl-imx-fb ?

Only wayland is supported ?

Actually, I just want to test our application built with Qt5.9 and run it with eglfs.

But during the configuration of Qt5, eglfs backend is not selected as during the confiug tests, I experience the following error:

imx8mqevk/usr/lib/gbm_viv.so: undefined reference to `wl_resource_get_user_data'

Any update is welcome.

Thanks.

Karim

0 Kudos

344 Views
bernhardfink
NXP Employee
NXP Employee

It has been decided for the i.MX 8M to support wayland and xwayland. Neither fb nor X11 builds are supported. For the market the i.MX 8M  is targeted for, the X11 and fb setups had a lower priority, removing them reduced the implementation and testing effort for the BSP.

You may check the fsl-community for their strategy, currently the 8M is not in the list of supported platforms, but will for sure come.

Regards,

Bernhard.

0 Kudos

344 Views
zyend
Contributor II

Hi Bernhard,

Thanks for your feedback.

Would you please tell me which market exactly the iMX8M is targeted for ?

Thanks.

Karim

0 Kudos

344 Views
Danube
Contributor IV

Hi Joan,

DISTRO=fsl-imx-x11 MACHINE=imx8mqevk source fsl-setup-release.sh -b build-20180329

Still the same build cairo package file

/build-x11-20180402/tmp/sysroots/imx8mqevk/usr/lib/gbm_viv.so: undefined reference to `wl_resource_get_user_data'
| collect2: error: ld returned 1 exit status
| make[4]: *** [cairo-sphinx] Error 1

344 Views
joanxie
NXP TechSupport
NXP TechSupport

I replied to you in your another case

0 Kudos

344 Views
kendalla59
Contributor I

Please provide a link to the other case. I'm stuck on this issue also.

0 Kudos

344 Views
joanxie
NXP TechSupport
NXP TechSupport

as I mentioned, current bsp only supports wayland, not support X11 and fb

0 Kudos