Xwayland on imx6

cancel
Showing results for 
Search instead for 
Did you mean: 

Xwayland on imx6

2,062 Views
sharvari
Contributor I

Hello,

I am using imx6q based custom board. I am running kernel linux-imx 4.1.15. I am using yocto krogoth layer for building rootfs. I am trying to run xwayland on board. I have imx-gpu-viv with fbdev backend. I am able to run wayland with it.

Wayland on launching, gives following message

xserver listening on display : 0 

After that when i run any X application, it fails.  Now if I run Xwayland on display 1 and then launch X application, it gives segmentation fault when eglInitialize is  called. 

What is the correct way to use Xwayland?  What are the steps/sequence for launching Xwayland,weston?  When both wayland and X are getting used, which imx-gpu-viv libraries needs to be present on board ? for eg. Do we need libEGL-x11.so or libEGL-wl.so or libEGL-fb.so?

-Thanks,

Sharvari Harisangam

0 Kudos
3 Replies

712 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Sharvari

please refer to attached Yocto Guide for available configurations.

Please use additional documentation and NXP BSPs on link below

http://www.nxp.com/products/software-and-tools/software-development-tools/i.mx-software-and-tools/i....

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

712 Views
sharvari
Contributor I

Hi Igor,

I have gone through this documentation and have my rootfs ready. Only confusion is with imx-gpu-viv recipe which provides libegl, libgal etc.  For running xwayland,

Which backend should I choose out of fbdev, x11 and Wayland. Because this recipe provides libraries like  libegl-wl.so, libegl-x11.so, libegl-fb.so and so on..

Out of this , which one should be present in rootfs for correct working of xwayland.

Currently I have included libraries for fb backend  and my x client application is crashing with segmentation fault during eglinitialize() api call.

So I need to understand why is that crashing . 

If I try with other x client which doesn't have egl calls, it runs perfectly.

-Thanks,

Sharvari Harisangam

0 Kudos

712 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Sharvari 

please refer to sect.13.1.1.4 Library Structure attached Linux Manual.

Regarding segmentation fault, had custom board passed memory test and

updated image with new ddr calibration coefficients (got from test) were used.

Best regards
igor

0 Kudos