Wifi is not up on imx8mqevk

cancel
Showing results for 
Search instead for 
Did you mean: 

Wifi is not up on imx8mqevk

582 Views
garyjiang
Contributor II

Hi,

Has anyone tried the wifi on the imx8mqevk. I got the below error during boot up 

root@imx8mqevk:~# [ 10.043247] ath10k_pci 0000:01:00.0: failed to ping firmware: -110
[ 10.049510] ath10k_pci 0000:01:00.0: failed to reset rx filter: -110
[ 10.152151] ath10k_pci 0000:01:00.0: could not init core (-110)
[ 10.158956] ath10k_pci 0000:01:00.0: could not probe fw (-110)

I followed these build instruction.

repo init -u https://source.codeaurora.org/external/imx/imx-manifest -b imx-linux-morty m imx-4.9.51-8mq_beta.xml 
MACHINE=imx8mqevk source fsl-setup-release.sh -b build
bitbake core-image-base

However, the demo image provided from the website does not report this error. I can see the wifi interface, but not working due to the below error. (wlp1s0 no wireless extensions.()

root@imx8mqevk:~# iwconfig
wlp1s0 no wireless extensions.

lo no wireless extensions.

eth0 no wireless extensions.

Thanks,

2 Replies

195 Views
garyjiang
Contributor II

Thanks for your reply.

1. When this message occurs, that is because the cfg80211 WEXT is not enabled. 

wlp1s0 no wireless extensions.

Solution:

Networking support->Wireless->cfg80211 wireless extensions compatibility"

CONFIG_WEXT_CORE=y 
CONFIG_WEXT_PROC=y 
CONFIG_CFG80211_WEXT=y

2.  If it is this error message, we need to replace the hw3.0/board.bin file.

root@imx8mqevk:~# [ 10.043247] ath10k_pci 0000:01:00.0: failed to ping firmware: -110
[ 10.049510] ath10k_pci 0000:01:00.0: failed to reset rx filter: -110
[ 10.152151] ath10k_pci 0000:01:00.0: could not init core (-110)
[ 10.158956] ath10k_pci 0000:01:00.0: could not probe fw (-110)
0 Kudos

195 Views
diegoadrian
NXP Employee
NXP Employee

Hello,

Probably you are not setting the WiFi connection.

Please try modifying the below file with your network specifications.

$nano /etc/wpa_supplicant.conf

ctrl_interface=/var/run/wpa_supplicant

            ctrl_interface_group=0

            update_config=1

 

            network={

                                    ssid="the name of your ssid connection"

                                    key_mgmt=WPA-PSK

                                    psk="your password"

                                    proto=WPA2

            }

Finally, run the below shell commands:

$wpa_supplicant -B -i wlp1s0 -c /etc/wpa_supplicant.conf -D nl80211

$udhcpc -i wlp1s0

Hope this can solve your problem.

Best Regards,

Diego.