Wi-Fi & BT support on MCIMX7ULP-EVK (Android BSP)

cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi & BT support on MCIMX7ULP-EVK (Android BSP)

374 Views
adwait
Contributor II

Hi,

I have installed Android P9.0.0_2.2.0 BSP from NXP [Link] onto my MCIMX7ULP-EVK board.

When I try to enable Wi-Fi using the Android UI (Settings -> Network & Internet), the slide-bar for enabling Wi-Fi gets activated on click but goes back to deactivated after a few seconds. I don't see any thing related to Wi-Fi being displayed on debug console / adb shell either.

Similarly, when I try to enable Bluetooth, that does not work either. On console I get messages like these:

rfkill: BT RF going to : off
rfkill: BT RF going to : on
mxc_bt_rfkill_reset

This is repeated a few times after with I get "Bluetooth keeps stopping" popup on Android screen.

--------

I am using MCIMX7ULP-EVK without any customisation.

The board has QCA9337 Wi-Fi & BT module present on the SOM.

I went through the Android docs [Link] for this BSP and the only things I could find on Wi-Fi or BT is in the Android_Release_Notes.pdf Page 5: Broadcom BCM43430 for Wi-Fi & BT support for i.MX 7ULP EVKB-SD.

But BCM43430 is not part of the MCIMX7ULP-EVK hardware.

No mention of QCA9337 anywhere in those docs.

------

 

Can someone confirm whether Wi-Fi & Bluetooth(QCA9337) support is added in this release of the Android BSP?

Or can some one give some hints as to how I can figure this out myself.

I have tried these rudimentary things already:

evk_7ulp:/ $ lsmod
Module Size Used by
brcmfmac 245760 0
brcmutil 16384 1 brcmfmac
evk_7ulp:/ $ su
evk_7ulp:/ # ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope: Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 TX bytes:0

Please help me with this.

Thanks a lot.

Labels (3)
0 Kudos
2 Replies

119 Views
adwait
Contributor II

Solved by doing a simple change in U-Boot settings.

The Android BSP released by NXP has drivers and software configuration for two communication modules: QCA9337(Qualacom) and BCM43430(Broadcom). However the BSP I was using is configured to use the BCM43430 module (which was not present on my board) by default. So, I needed to change the configuration to use QCA9337(Qualacom) module instead.

This was done by changing androidboot.wifivendor=qca in the kernel arguments. 

It is working now - thanks to NXP support.

0 Kudos

119 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Adwait

one can try Demo Image

Demo Images – i.MX 7ULP EVKB Board and Platform

then:

 Open the desktop
 Click on Settings
 Click on Network and Internet
 Select the wifi access point and enter proper credentials
 Wait for things to connect

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos