Wi-Fi/BT(LBEE5ZZ1PJ) on imx8mm custom board

cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi/BT(LBEE5ZZ1PJ) on imx8mm custom board

146 Views
ganesh_k
Contributor III

Hi team...

       We are working imx8mm custom board having the Wi-Fi/BT chip is "LBEE5ZZ1PJ" and imx8mm evk board having Wi-Fi/BT chip is "LBEE5KL1PJ" series. Both are QCA9377 based only. Wi-Fi/BT (LBEE5KL1PJ) is working on evk with default images, but Wi-Fi/BT (LBEE5ZZ1PJ) is not working with same images on imx8mm custom board.

Do we need to change anything in software level cause of this series change of Wi-Fi/BT chip.

test logs are here:
BLE log:

hciattach /dev/ttymxc0 any 115200 flow
Device setup complete
root@arm:~# [ 59.327961] Bluetooth: hci0: command 0x1003 tx timeout
cd [ 61.343958] Bluetooth: hci0: command 0x1001 tx timeout
[ 63.359961] Bluetooth: hci0: command 0x1009 tx timeout
^C
root@arm:~# hciconfig hci0 up
[ 93.311962] Bluetooth: hci0: command 0x1003 tx timeout
[ 95.327960] Bluetooth: hci0: command 0x1001 tx timeout
[ 97.343955] Bluetooth: hci0: command 0x1009 tx timeout
Can't init device hci0: Connection timed out (110)

Wifi log:

root@arm:~# ifconfig eth0 down
root@arm:~# ifconfig wlan0 up
root@arm:~# wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf
Successfully initialized wpa_supplicant
rfkill: Cannot open RFKILL control device

root@arm:~# ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 106 bytes 8432 (8.4 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 106 bytes 8432 (8.4 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 48:eb:62:a6:5e:55 txqueuelen 3000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

root@arm:~# dhclient -v wlan0
Internet Systems Consortium DHCP Client 4.4.1
Copyright 2004-2018 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

can't create /var/lib/dhcp/dhclient.leases: No such file or directory
Listening on LPF/wlan0/48:eb:62:a6:5e:55
Sending on LPF/wlan0/48:eb:62:a6:5e:55
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3 (xid=0x7cd75374)
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3 (xid=0x7cd75374)
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4 (xid=0x7cd75374)
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7 (xid=0x7cd75374)

--------------------------------------------------------
Please suggest any solution to solve this issue.


Thanks & Regards

Ganesh.K

0 Kudos
1 Reply

137 Views
jamesbone
NXP TechSupport
NXP TechSupport

Unfortunately as you already check the Qualcomm module works fine, which means that the interface driver it is working correctly, the change that you need to make it is from the Module Driver,  you need to contact your module maker or directly Qualcomm in order to get a proper driver for this module.

 

 

0 Kudos