Why doesn't nfs-utils build in LTIB?

cancel
Showing results for 
Search instead for 
Did you mean: 

Why doesn't nfs-utils build in LTIB?

Jump to solution
1,006 Views
bonzo
NXP Employee
NXP Employee

I am unable to build the nfs-utils when I select this option in the package list.

This is for the iMX6Q SDB, SDK L3.0.35_4.0.0.

I have enabled both NFS client and server in the kernel.

Below is the error.

Any suggestions?

--Brad

/home/brad/freescale/imx6/ltib/rpm/BUILD/nfs-utils-1.1.0/utils/exportfs/exportfs.c:397: undefined reference to `S_ISDIR'

/home/brad/freescale/imx6/ltib/rpm/BUILD/nfs-utils-1.1.0/utils/exportfs/exportfs.c:397: undefined reference to `S_ISREG'

collect2: ld returned 1 exit status

make[2]: *** [exportfs] Error 1

make[2]: Leaving directory `/home/brad/freescale/imx6/ltib/rpm/BUILD/nfs-utils-1.1.0/utils/exportfs'

make[1]: *** [all-recursive] Error 1

make[1]: Leaving directory `/home/brad/freescale/imx6/ltib/rpm/BUILD/nfs-utils-1.1.0/utils'

make: *** [all-recursive] Error 1

error: Bad exit status from /home/brad/freescale/imx6/ltib/tmp/rpm-tmp.11482 (%build)

Labels (3)
Tags (3)
0 Kudos
1 Solution
321 Views
weidong_sun
NXP TechSupport
NXP TechSupport

Hello,Bradley,

     I tried to compiled nfs-utils-1.1.0, please refter to the following steps:

(1)Using ltib command to release source code.

# ./ltib -m prep -p nfs-utils

Then source code will release to path "ltib/rpm/BUILD/nfs-utils-1.1.0"

(2)Add a Header file into 2 files

** open ltib/rpm/BUILD/nfs-utils-1.1.0/utils/exportfs/exportfs.c , and add "#include <sys/stat.h>"

**open ltib/rpm/BUILD/nfs-utils-1.1.0/utils/mount/mount.c , and add "#include <sys/stat.h>"

(3)Modify nfs-utils.spec file

**open ltib/dist/lfs-5.1/nfs-utils/nfs-utils.spec, and ajust configure line like following:

./configure --prefix=%{_prefix} --host=$CFGHOST --build=%{_build} \

            --disable-nfsv4 --disable-uuid --disable-gss --without-tcp-wrappers

(4)Begin to compile nfs-utils

# ./ltib -m scbuild -p nfs-utils

You should compile it successfully ! attachment is log, for you a reference to check issue.

Regards,

Weidong

View solution in original post

0 Kudos
3 Replies
321 Views
SLICE
Contributor IV

Hi All,

My customer also faces the same issue.

Does anyone has ideas to solve the issue on L3.0.35_4.0.0?

BR

0 Kudos
322 Views
weidong_sun
NXP TechSupport
NXP TechSupport

Hello,Bradley,

     I tried to compiled nfs-utils-1.1.0, please refter to the following steps:

(1)Using ltib command to release source code.

# ./ltib -m prep -p nfs-utils

Then source code will release to path "ltib/rpm/BUILD/nfs-utils-1.1.0"

(2)Add a Header file into 2 files

** open ltib/rpm/BUILD/nfs-utils-1.1.0/utils/exportfs/exportfs.c , and add "#include <sys/stat.h>"

**open ltib/rpm/BUILD/nfs-utils-1.1.0/utils/mount/mount.c , and add "#include <sys/stat.h>"

(3)Modify nfs-utils.spec file

**open ltib/dist/lfs-5.1/nfs-utils/nfs-utils.spec, and ajust configure line like following:

./configure --prefix=%{_prefix} --host=$CFGHOST --build=%{_build} \

            --disable-nfsv4 --disable-uuid --disable-gss --without-tcp-wrappers

(4)Begin to compile nfs-utils

# ./ltib -m scbuild -p nfs-utils

You should compile it successfully ! attachment is log, for you a reference to check issue.

Regards,

Weidong

0 Kudos
321 Views
OtavioSalvador
Senior Contributor II

Hello Bradley,

maybe you could give a try in Yocto? It does has it working fine and might make your life easier (in long term) ;-)

Regards,

0 Kudos