Why are ping times so bad on imx8 mini evk?

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 

Why are ping times so bad on imx8 mini evk?

1,018 次查看
hutchman
Contributor II

Hello,

We have a bunch of imx8mm Mini Evk boards.  One of our researchers noticed the ping times were averaging around 2.5ms and thinks that's way too high.  He has pinged the evk from a pc and also from one evk to another via a Ethernet switch and directly connected with same results.

So just wanted to get thoughts on what might be causing that.

I tried playing with setting net.ipv4.tcp_low_latency=1 and it didn't appear to make much of a difference.

When I run wireshark I see lots of ARP traffic going on and I suspect it's because of Avahi and other stuff installed.

Regards,

Brian

标签 (2)
标记 (1)
0 项奖励
2 回复数

531 次查看
NG_R3
Contributor I

Hi there,

I'm facing a similar issue with imx8M Plus, kernel 5.15.60.

I know it's been 2 years, maybe it was enough time to sort this issue out? 

If so, can you please share some details about the root cause of the problem and a possible solution?

Thanks a lot,

Nir.

0 项奖励

943 次查看
gusarambula
NXP TechSupport
NXP TechSupport

Hello Brian,

It would make sense that Avahi could make the ping a bit slower due to the ARP request, although shouldn’t affect that much. Have you tested the ethernet with a smaller image that does not contains it? If you want to go to the bate minimum you could test it with the core-image-minimal. Alternatively, you may try to remove it from the image build to see how it affects the ping time.

Regards,

0 项奖励