When booting from flash on MIMXRT1060-EVK freemaster doesn't measure

cancel
Showing results for 
Search instead for 
Did you mean: 

When booting from flash on MIMXRT1060-EVK freemaster doesn't measure

35 Views
filip091
Contributor I

Hello,

I would like to ask if you don't know why when I configure my program to not program flash and only run from RAM it's works properly and freemaster measures values correctly, but when I configure project in MCUXpreso to program flash and run from flash it doesn't work properly. Freemaster can connect to board and measure values, but it show constant numbers.

Thanks for your time.

Labels (2)
0 Kudos
2 Replies

27 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi @filip091 

  Do you try our SDK freemaster code:

SDK_2_10_0_EVK-MIMXRT1060\boards\evkmimxrt1060\freemaster_examples\fmstr_uart

 Download this code to the flash, whether it works OK on your side or not?

I have tested the SDK project on my side, and download it to the flash, it works OK.

kerryzhou_0-1626932791478.png

You mentioned interrupt, what interrupt you are using?

I suggest you test the SDK code at first.

If you still have questions about it, please kindly let me know.

Best Regards,

Kerry

 

 

0 Kudos

30 Views
filip091
Contributor I

I found out that it doesn't work because interrupts doesn't work properly. I don't know why but when my project is configured to run from flash it doesn't work. I set breakpoint in interrupt handlers but it never stops there so I assume these interrupts never happen and I need to figure out why.

I would be glad if you could help me.

0 Kudos