Vivante drivers fail on recent releases.

cancel
Showing results for 
Search instead for 
Did you mean: 

Vivante drivers fail on recent releases.

2,029 Views
danmerillat
Contributor III

Tested 3.14.28-6QP_ga and 3.14.38_6QP_ga BSPs

Built both BSP images with repo/bitbake, configured as "./fsl-setup-release.sh -e fb -b build"

Verified the non-accelerated framebuffer works.

Installed the image to our board (sabresd based) and attempted to run the demos in /opt/fsl-gpu-sdk.

Results with 3.14.28:

They all fail with:

ERROR: demo setup failed with: eglCreateWindowSurface(m_hDisplay, m_hConfig, hWindow, nullptr) failed with error

code 12291 at source/FslDemoHostEGL/EGLDemoHost.cpp(575)                                                        

That's 0x3003,  EGL_BAD_ALLOC.   There's a slightly different error when /dev/galcore is inaccessible, and strace shows it accessing the device and issuing successful IOCTLs.

I tried debugging but it gets lost deep in the binary-only driver. 

3.14.38: Kernel panic in the galcore driver (attempting to set clocks before initializing them, null pointer deref)

The problem is unlikely to be our board: the 3.10.53 release is fine, but doesn't support GLES3 which we need.

The kernel reports "Galcore version 5.0.11.33433", verified that the userspace is also 5.0.11.33433.

Is GLES on the framebuffer officially supported?  Running Xorg or Wayland or android would be a massive overkill for our project.

Labels (4)
0 Kudos
7 Replies

439 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hi Dan,

3.14.38 6QP is not officially supported yet, however I will try to reproduced the issue and if it is a bug, will report it immediately to developer team. Thanks for the catch, let you know the outcome.

Regards

0 Kudos

439 Views
stefan_riesen
Contributor I

Hi Bio_TICFSL

I have the same problem (i.e. EGL_BAD_ALLOC when running GLES against the 3.14.28 Kernel) as Dan. Unfortunately going back to an older Kernel is not an option, either. So I would be also very interessted in a soon resolution of that issue.

But, we use a iMX 6Q not a 6QP - does this make a difference concerning the described issue?

Thank you and best regards

Stefan

0 Kudos

439 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hi Stefan,

Compiling vivante demos, and tested with MX6Q Sabre SD and 3.14.28 works well on my side, please make sure that you have enable the vivante gpu support in kernel configuration build.

Regards

0 Kudos

439 Views
aznjaput
Contributor III

Was this ever figured out? I'm running into the exact same issue going to kernel 3.14.28. I have an openGL app that was built against 3.10.53 and that ran without any issues. Now when I compile the same app against 3.14.28 and try to run it, I get the same error:

ERROR: demo setup failed with: eglCreateWindowSurface(m_hDisplay, m_hConfig, hWindow, nullptr) failed with error code 12291 at source/FslDemoHostEGL/EGLDemoHost.cpp(473)

kernel: 3.14.28

Galcore version 5.0.11.25762

fb backend

bitbake fsl-image-multimedia

Thanks,

0 Kudos

439 Views
aznjaput
Contributor III

Similar issue was solved at:

EGL eglCreateWindowSurface issue 3.14.28

Thanks,

0 Kudos

439 Views
stefan_riesen
Contributor I

Yes, GPU Support is activated in the Kernel and the framebuffer device is configured in the device tree, i.e. /dev/fb0 and /dev/fb1 are created. We use the Vivante firmware version 5.0.11.p4.5 and are building with Yocto (Image fsl-image-multimedia-full).

So, I would as Dan also be interessted, whether your test was with or without x11.

Thank you and best regards

Stefan Riesen

0 Kudos

439 Views
danmerillat
Contributor III

Was that working with framebuffer?  I'm using non-x11 builds (./fsl-setup-release.sh -e fb)

If so, can you send your working build/local.conf so I can try that.

0 Kudos