VPU h264 encoding on i.MX6Q - Linaro (L3.035_1.1.0)

cancel
Showing results for 
Search instead for 
Did you mean: 

VPU h264 encoding on i.MX6Q - Linaro (L3.035_1.1.0)

Jump to solution
469 Views
mathieut
Contributor I

Hello,

I am currently trying to use the VPU on my i.MX6Q Sabre SD board. I read the VPU API document and (as a 1st test) I am using the sample mxc_vpu-test.out available in the /unit_tests folder.

I read in the VPU documentation that the only format available is YUV 4:2:0 so I download from this website (Xiph.org :: Derf's Test Media Collection) a 720p file in 4:2:0 format.

My command line is the folowing one: ./mxc_vpu_test.out -E "-i input.y4m -w 1280 -h 720 -f 2 -t 0 output.264"

The output is not correct, the color is wierd and the frame is not correct as well.

Please, can you give me any information about what I did wrong or provide me a working test ?

Regards

Labels (3)
0 Kudos
1 Solution
150 Views
machlee
Contributor II

Hi,

I tried like below.

mxc_vpu_test.out -E "-o 720_b1000.h264 -f 2 -l 0 -c 1000 -r 0 -w 1280 -h 720 -b 1000 -g 30 "

to get raw picture image from camera and encode h.264 by 720.

then you can play 720_b1000.h264 with VLC player.

View solution in original post

0 Kudos
1 Reply
151 Views
machlee
Contributor II

Hi,

I tried like below.

mxc_vpu_test.out -E "-o 720_b1000.h264 -f 2 -l 0 -c 1000 -r 0 -w 1280 -h 720 -b 1000 -g 30 "

to get raw picture image from camera and encode h.264 by 720.

then you can play 720_b1000.h264 with VLC player.

0 Kudos