VLC error on pico-pi-imx7-emmc

cancel
Showing results for 
Search instead for 
Did you mean: 

VLC error on pico-pi-imx7-emmc

Jump to solution
1,531 Views
smitpanchal
Contributor II

Hi,

 

Builded VLC player using yocto project with the following local.conf file but the vlc player doesn’t play mp3 and m3u files, it gives below error:

 

===========================

^Croot@pico-imx7:~# vlc /media/alexa_response_dump.mp3

VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)

[010951d0] core demux meta error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so

[010951d0] core demux meta error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so

[01095160] core xml reader error: XML reader not found

[010b1580] core interface error: no suitable interface module

[00fb20d0] core libvlc error: interface "globalhotkeys,none" initialization failed

[010b1580] dbus interface error: Failed to connect to the D-Bus session daemon: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11

[010b1580] dbus interface error: Failed to connect to the D-Bus session daemon: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11

[010b1580] core interface error: no suitable interface module

[00fb20d0] core libvlc error: interface "dbus,none" initialization failed

[00fb20d0] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.

[010b1580] core interface error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so

[010b1580] core interface error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so

Remote control interface initialized. Type `help' for help.

[76403f68] core art finder error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so

[76403f68] core art finder error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so

[71f03168] core art finder error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so

[71f03168] core art finder error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so

[71f03168] core art finder error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so

[71f03168] core art finder error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so

[76403f20] core art finder error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so

[76403f20] core art finder error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so

[71f0cfc0] core decoder error: Codec `mpga' (MPEG Audio layer 1/2) is not supported.

[71f0cfc0] core decoder error: Codec not supported

[71f0cfc0] core decoder error: VLC could not decode the format "mpga" (MPEG Audio layer 1/2)

================================================

 

My local.conf contents are:

 

=====================================

MACHINE ??= 'pico-imx7'

DISTRO ?= 'fsl-imx-x11'

PACKAGE_CLASSES ?= "package_deb"

EXTRA_IMAGE_FEATURES = "debug-tweaks package-management"

USER_CLASSES ?= "buildstats image-mklibs image-prelink"

PATCHRESOLVE = "noop"

BB_DISKMON_DIRS = "\

    STOPTASKS,${TMPDIR},1G,100K \

    STOPTASKS,${DL_DIR},1G,100K \

    STOPTASKS,${SSTATE_DIR},1G,100K \

    STOPTASKS,/tmp,100M,100K \

    ABORT,${TMPDIR},100M,1K \

    ABORT,${DL_DIR},100M,1K \

    ABORT,${SSTATE_DIR},100M,1K \

    ABORT,/tmp,10M,1K"

PACKAGECONFIG_append_pn-qemu-native = " sdl"

PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"

ASSUME_PROVIDED += "libsdl-native"

CONF_VERSION = "1"

 

PREFERRED_PROVIDER_jpeg = "libjpeg-turbo"

PREFERRED_PROVIDER_shlib = "libjpeg-turbo"

PREFERRED_PROVIDER_jpeg-native = "libjpeg-turbo-native"

PREFERRED_PROVIDER_virtual/mesa = "mesa"

PREFERRED_PROVIDER_virtual/libgl = "gpu-viv-bin-mx6q"

PREFERRED_PROVIDER_mesa-driver-swrast = "mesa-gl"

PREFERRED_VERSION_xserver-nodm-init = "1.0"

 

BB_NUMBER_THREADS = '12'

PARALLEL_MAKE = '-j 12'

 

DL_DIR ?= "${BSPDIR}/downloads/"

ACCEPT_FSL_EULA = "1"

 

LICENSE_FLAGS_WHITELIST ?= "commercial_gst-fluendo-mp3 \

                             commercial_gst-openmax \

                             commercial_gst-plugins-ugly \

                             commercial_gst-ffmpeg \

                             commercial_gstreamer1.0-libav \

                             commercial_lame \

                             commercial_libav \

                             commercial_libpostproc \

                             commercial_mplayer2 \

                             commercial_x264 \

                             commercial_libmad \

                             commercial_libav \

                             commercial_mpeg2dec \

                             commercial_qmmp \

                             oracle_java \

                             commercial \

                             alexa_materials \

                             "

 

CORE_IMAGE_EXTRA_INSTALL += "chromium libexif"

IMAGE_INSTALL_append = " vlc"

IMAGE_INSTALL_append = " apache-maven"

IMAGE_INSTALL_append = " nodejs"

IMAGE_INSTALL_append = " nodejs-npm"

IMAGE_INSTALL_append = " oracle-jse-jdk-arm32"

IMAGE_INSTALL_append = " alexa"

==============================

 

I may have to install some vlc plugins to play mp3 and m3u files, can you please help which plugins I need to install and how to modify local.conf file?

 

Thanks,

Smit.

0 Kudos
1 Solution
509 Views
smitpanchal
Contributor II

Hello,

Thanks for reply.

I found out that MPEG plugin support was not enabled in the vlc, so I manually added that part to the local.conf file and finally was able to play the mp3 file.

Changes:

PACKAGECONFIG_append_pn-vlc = " mad"
PACKAGECONFIG_append_pn-vlc = " gnutls"
PACKAGECONFIG_append_pn-vlc = " mkv"
RDEPENDS_vlc = "libmad"

IMAGE_INSTALL_append = " libmad"

Thanks,
Smit.

View solution in original post

0 Kudos
3 Replies
509 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Smit Panchal,

I think the VLC player recipe does not include codecs, so you would need to provide these separately. You have the licenses set, but I’m not sure if your image is providing the codec packages and if VLC is being able to access them.

I’m not sure if there is a codec package, let me check. Otherwise you would need to add the codec files manually.

Regards,

0 Kudos
510 Views
smitpanchal
Contributor II

Hello,

Thanks for reply.

I found out that MPEG plugin support was not enabled in the vlc, so I manually added that part to the local.conf file and finally was able to play the mp3 file.

Changes:

PACKAGECONFIG_append_pn-vlc = " mad"
PACKAGECONFIG_append_pn-vlc = " gnutls"
PACKAGECONFIG_append_pn-vlc = " mkv"
RDEPENDS_vlc = "libmad"

IMAGE_INSTALL_append = " libmad"

Thanks,
Smit.

0 Kudos
509 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Smit,

Thanks for sharing your findings! I'm sure they will help other community users.

Regards,

0 Kudos