Unable to set cpufreq in Kirkstone (5.15.71)

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to set cpufreq in Kirkstone (5.15.71)

1,794 Views
kishan_dudhatra
Contributor III

Hi folks,

I am starting a new thread because the previous one (https://community.nxp.com/t5/i-MX-Processors/cpufreq-set-not-working/td-p/1678763) has not been resolved. 

Could you please look into this thread?

Regards,
Kishan Dudhatra
0 Kudos
21 Replies

60 Views
himanshu_bhavani
Contributor I

Hi @kishan_dudhatra,

One of my colleague is able to resolve the issue.

This is a workaround patch, Please check this patch at your end.

This patch will resolve your issue!

Thanks & Regards,

Himanshu Bhavani

BSP Engineer at Silicon Signals Pvt Ltd | https://siliconsignals.io/

 

0 Kudos

80 Views
wouher
Contributor II

I ran into the same; in my case the problem was that between kernel 5.4 and 5.15 the of_match method changed in the pca9450 driver.
This caused regulator_dev_lookup to keep deferring, if the syntax in the dts node isn't changed accordingly.
Look for the change in semantics regarding pca9450 dts node in the NXP EVK examples between 5.4 and 5.15.

e.g.

buck1_reg: regulator@0 {
    reg = <0>;
    regulator-compatible = "buck1";

vs

buck1: BUCK1{
regulator-name = "BUCK1";

0 Kudos

1,743 Views
kishan_dudhatra
Contributor III

Hi @joanxie 

We are using the NXP PMIC and the part no is pca9450.
Could you please provide the link of the PMIC patch?

Regards,
Kishan Dudhatra
0 Kudos

1,606 Views
kishan_dudhatra
Contributor III

@joanxie 

 

PMIC is also probed successfully.

kishan_dudhatra_0-1690032382581.png

 

Regards,
Kishan Dudhatra
Tags (1)
0 Kudos

1,679 Views
kishan_dudhatra
Contributor III

@joanxie Can you please reply?

Regards,
Kishan Dudhatra
0 Kudos

1,670 Views
joanxie
NXP TechSupport
NXP TechSupport

sorry for delay, these days I couldn't access community, you can refer to this dts to modify your ROHM pmic

https://github.com/nxp-imx/linux-imx/blob/lf-6.1.y/arch/arm64/boot/dts/freescale/imx8mm-evk-qca-wifi...

0 Kudos

1,646 Views
kishan_dudhatra
Contributor III

Hi @joanxie 

We are using the PCA9450A, not the ROHM PMIC.

Can you please provide a solution for nxp,pca9450 PMIC?

Regards,
Kishan Dudhatra
Tags (1)
0 Kudos

1,460 Views
joanxie
NXP TechSupport
NXP TechSupport

did you use nxp board or your customized board?

0 Kudos

1,458 Views
kishan_dudhatra
Contributor III

@joanxie 

I am using the customized board.

The CPU governor on the same board works on Zeus.

Regards,
Kishan Dudhatra
0 Kudos

1,452 Views
joanxie
NXP TechSupport
NXP TechSupport

only heard that  ROMH PMIC has this issue, let me reproduce this issue on nxp imx8mm evkb board when I come back to office

0 Kudos

1,440 Views
r_trivedi123
Contributor IV

Hi @joanxie  and @kishan_dudhatra ,

I am also facing the similar issue, did you get it working ?

Also I have been through the NXP issue list and found that other people are also facing the similar challenge.

Here is the similar issue link
IMX8mm cpu-freq scaling issue  

If not resolved, please help us here NXP team.

--
BR.

0 Kudos

1,379 Views
joanxie
NXP TechSupport
NXP TechSupport

I tested nxp imx8mm evkb board which uses pcm9450A, I couldn't reproduce this issue, I attached my logfile, maybe you can compare with it

0 Kudos

1,372 Views
r_trivedi123
Contributor IV

Hi @joanxie ,

Thanks for the replay and logs I will analyze,
Also meantime can you do one more favor by sending used device tree and kernel configs or perhaps (zcat /proc/config.gz) ?

This will help me understand if by chance I have disabled anything unknowingly ?

Appreciate your support.

--
BR

0 Kudos

1,355 Views
joanxie
NXP TechSupport
NXP TechSupport

pls find the attachment, I use the prebuilt images without any modification

 

0 Kudos

1,414 Views
dtony
Contributor III

It is very simple, just a back-ports in dts. 

I have sent you and kishan_dudhatra by private message. 

0 Kudos

1,406 Views
r_trivedi123
Contributor IV

Hi @dtony ,

Thanks for the support, but the problem is My hardware doesn't uses ROHM PMIC, its PCA9450.

--
BR.

0 Kudos

1,393 Views
r_trivedi123
Contributor IV

Hi @dtony ,

Thanks for the replay.

Actual problem is Unable to set cpufreq in Kirkstone, I am unable to get the /sys entries even.
And not able to change the cpufreq (without /sys ?).

With the help of NXP team (& of-course yours), currently we are on PMIC checking stage.

--
BR


0 Kudos

1,383 Views
dtony
Contributor III

Suggest to get the whole boot log. From the power on till linux console. 

Confirm the linux kernel configuration is the same as bsp release. 

0 Kudos

1,371 Views
r_trivedi123
Contributor IV

@dtony, Noted, also asked @joanxie for DTS and Configs to compare with my setup.

Thanks for helping.

--
BR

0 Kudos

1,397 Views
dtony
Contributor III

Could  not understand the problem. 

The pca9450 pmic is supported by default in 5.15.71. 

0 Kudos