Unable to print anything on console putty and minicom

cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to print anything on console putty and minicom

Jump to solution
154 Views
kenizgandhi
Contributor III

I am using NXP i.mx8m plus evk board. I have set the baud rate to 115200 and flow control to none and done all the settings and connections according to the given in Get started module. I have even connected the USB serial device and selected the com port as 3rd COM port. But nothing is getting printed on console. it is blank. Till yesterday it was getting printed. But today it is not. Can you please help me?

Tags (2)
0 Kudos
1 Solution
102 Views
Yuri
NXP TechSupport
NXP TechSupport

@kenizgandhi 
Hello,

   I just tried the demo image "imx-image-multimedia-imx8mpevk.wic" of L5.10.9  (SD card).
All is working.

Regards,
Yuri.

View solution in original post

0 Kudos
7 Replies
134 Views
kenizgandhi
Contributor III

@Yuri 

After booting from sd-card is done,  I got the following output and uboot is not accepting any input from keyboard.

Welcome to minicom 2.7.1

OPTIONS: I18n
Compiled on Dec 23 2019, 02:06:26.
Port /dev/ttyUSB2, 03:18:21

Press CTRL-A Z for help on special keys


U-Boot SPL 2020.04-5.10.9-1.0.0+gad7b74b415 (Mar 05 2021 - 07:05:56 +0000)
DDRINFO: start DRAM init
DDRINFO: DRAM rate 4000MTS
DDRINFO:ddrphy calibration done
DDRINFO: ddrmix config done
Normal Boot
Trying to boot from BOOTROM
image offset 0x8000, pagesize 0x200, ivt offset 0x0
NOTICE: BL31: v2.4(release):lf-5.10.y-1.0.0-rc2-1-gba76d337e
NOTICE: BL31: Built : 08:27:48, Mar 1 2021


U-Boot 2020.04-5.10.9-1.0.0+gad7b74b415 (Mar 05 2021 - 07:05:56 +0000)

CPU: i.MX8MP[8] rev1.1 1800 MHz (running at 1200 MHz)
CPU: Commercial temperature grade (0C to 95C) at 25C
Reset cause: POR
Model: NXP i.MX8MPlus LPDDR4 EVK board
DRAM: 6 GiB
TCPC: Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C2 0x50]
SNK.Power3.0 on CC2
tcpc_pd_receive_message: Polling ALERT register, TCPC_ALERT_RX_STATUS bit failed, ret = -62
Power supply on USB2
TCPC: Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C1 0x50]
MMC: FSL_SDHC: 1, FSL_SDHC: 2
Loading Environment from MMC... Run CMD11 1.8V switch
*** Warning - bad CRC, using default environment

[*]-Video Link 0Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
fail to get display timings
probe video device failed, ret -19

[0] lcd-controller@32e80000, video
[1] mipi_dsi@32e60000, video_bridge
[2] adv7535@3d, panel
Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
fail to get display timings
probe video device failed, ret -19
In: serial
Out: serial
Err: serial

BuildInfo:
- ATF ba76d33
- U-Boot 2020.04-5.10.9-1.0.0+gad7b74b415

Run CMD11 1.8V switch
switch to partitions #0, OK
mmc1 is current device
flash target is MMC:1
Run CMD11 1.8V switch
Net:
Warning: ethernet@30be0000 using MAC address from ROM

Warning: ethernet@30bf0000 using MAC address from ROM
eth0: ethernet@30be0000, eth1: ethernet@30bf0000 [PRIME]
Fastboot: Normal
Normal Boot
Hit any key to stop autoboot: 0
Run CMD11 1.8V switch
switch to partitions #0, OK
mmc1 is current device
Run CMD11 1.8V switch
Booting from net ...
ethernet@30bf0000 Waiting for PHY auto negotiation to complete.................
U-Boot SPL 2020.04-5.10.9-1.0.0+gad7b74b415 (Mar 05 2021 - 07:05:56 +0000)
DDRINFO: start DRAM init
DDRINFO: DRAM rate 4000MTS
DDRINFO:ddrphy calibration done
DDRINFO: ddrmix config done
Normal Boot
Trying to boot from BOOTROM
image offset 0x8000, pagesize 0x200, ivt offset 0x0
NOTICE: BL31: v2.4(release):lf-5.10.y-1.0.0-rc2-1-gba76d337e
NOTICE: BL31: Built : 08:27:48, Mar 1 2021


U-Boot 2020.04-5.10.9-1.0.0+gad7b74b415 (Mar 05 2021 - 07:05:56 +0000)

CPU: i.MX8MP[8] rev1.1 1800 MHz (running at 1200 MHz)
CPU: Commercial temperature grade (0C to 95C) at 25C
Reset cause: POR
Model: NXP i.MX8MPlus LPDDR4 EVK board
DRAM: 6 GiB
TCPC: Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C2 0x50]
Power supply on USB2
TCPC: Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C1 0x50]
MMC: FSL_SDHC: 1, FSL_SDHC: 2
Loading Environment from MMC... Run CMD11 1.8V switch
*** Warning - bad CRC, using default environment

[*]-Video Link 0Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
fail to get display timings
probe video device failed, ret -19

[0] lcd-controller@32e80000, video
[1] mipi_dsi@32e60000, video_bridge
[2] adv7535@3d, panel
Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
fail to get display timings
probe video device failed, ret -19
In: serial
Out: serial
Err: serial

BuildInfo:
- ATF ba76d33
- U-Boot 2020.04-5.10.9-1.0.0+gad7b74b415

Run CMD11 1.8V switch
switch to partitions #0, OK
mmc1 is current device
flash target is MMC:1
Run CMD11 1.8V switch
Net:
Warning: ethernet@30be0000 using MAC address from ROM

Warning: ethernet@30bf0000 using MAC address from ROM
eth0: ethernet@30be0000, eth1: ethernet@30bf0000 [PRIME]
Fastboot: Normal
Normal Boot
Hit any key to stop autoboot: 0
Run CMD11 1.8V switch
switch to partitions #0, OK
mmc1 is current device
Run CMD11 1.8V switch
Booting from net ...
ethernet@30bf0000 Waiting for PHY auto negotiation to complete........
U-Boot SPL 2020.04-5.10.9-1.0.0+gad7b74b415 (Mar 05 2021 - 07:05:56 +0000)
DDRINFO: start DRAM init
DDRINFO: DRAM rate 4000MTS
DDRINFO:ddrphy calibration done
DDRINFO: ddrmix config done
Normal Boot
Trying to boot from BOOTROM
image offset 0x8000, pagesize 0x200, ivt offset 0x0
NOTICE: BL31: v2.4(release):lf-5.10.y-1.0.0-rc2-1-gba76d337e
NOTICE: BL31: Built : 08:27:48, Mar 1 2021


U-Boot 2020.04-5.10.9-1.0.0+gad7b74b415 (Mar 05 2021 - 07:05:56 +0000)

CPU: i.MX8MP[8] rev1.1 1800 MHz (running at 1200 MHz)
CPU: Commercial temperature grade (0C to 95C) at 25C
Reset cause: POR
Model: NXP i.MX8MPlus LPDDR4 EVK board
DRAM: 6 GiB
TCPC: Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C2 0x50]
Power supply on USB2
TCPC: Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C1 0x50]
MMC: FSL_SDHC: 1, FSL_SDHC: 2
Loading Environment from MMC... Run CMD11 1.8V switch
*** Warning - bad CRC, using default environment

[*]-Video Link 0Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
fail to get display timings
probe video device failed, ret -19

[0] lcd-controller@32e80000, video
[1] mipi_dsi@32e60000, video_bridge
[2] adv7535@3d, panel
Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
fail to get display timings
probe video device failed, ret -19
In: serial
Out: serial
Err: serial

BuildInfo:
- ATF ba76d33
- U-Boot 2020.04-5.10.9-1.0.0+gad7b74b415

Run CMD11 1.8V switch
switch to partitions #0, OK
mmc1 is current device
flash target is MMC:1
Run CMD11 1.8V switch
Net:
Warning: ethernet@30be0000 using MAC address from ROM

Warning: ethernet@30bf0000 using MAC address from ROM
eth0: ethernet@30be0000, eth1: ethernet@30bf0000 [PRIME]
Fastboot: Normal
Normal Boot
Hit any key to stop autoboot: 0
Run CMD11 1.8V switch
switch to partitions #0, OK
mmc1 is current device
Run CMD11 1.8V switch
Booting from net ...
ethernet@30bf0000 Waiting for PHY auto negotiation to complete......................................... TIMEOUT !
phy_startup() failed: -110FAILED: -110ethernet@30be0000 Waiting for PHY auto negotiation to complete......................................... TIMEOUT !
Could not initialize PHY ethernet@30be0000
BOOTP broadcast 1
BOOTP broadcast 2
BOOTP broadcast 3
BOOTP broadcast 4
BOOTP broadcast 5
BOOTP broadcast 6
BOOTP broadcast 7
BOOTP broadcast 8
BOOTP broadcast 9
BOOTP broadcast 10
BOOTP broadcast 11
BOOTP broadcast 12
BOOTP broadcast 13
BOOTP broadcast 14
BOOTP broadcast 15
BOOTP broadcast 16
BOOTP broadcast 17

Retry time exceeded; starting again
ethernet@30be0000 Waiting for PHY auto negotiation to complete......................................... TIMEOUT !
Could not initialize PHY ethernet@30be0000
BOOTP broadcast 1
BOOTP broadcast 2
BOOTP broadcast 3
BOOTP broadcast 4
BOOTP broadcast 5
BOOTP broadcast 6
BOOTP broadcast 7
BOOTP broadcast 8
BOOTP broadcast 9
BOOTP broadcast 10
BOOTP broadcast 11
BOOTP broadcast 12
BOOTP broadcast 13
BOOTP broadcast 14
BOOTP broadcast 15
BOOTP broadcast 16
BOOTP broadcast 17

Retry time exceeded; starting again
WARN: Cannot load the DT

u-boot=>

 

and when i try to upload zip file to emmc using uuu

root@ubuntu:~/mfgtools/uuu# ./uuu /home/kenizpgandhi/Downloads/LF_v5.10_1.0.0_images_IMX8MPEVK.zip
uuu (Universal Update Utility) for nxp imx chips -- libuuu_1.4.127-11-g051a8fe

Success 0 Failure 0 Wait for Known USB Device Appear...

Prep 1/ 0 [=================100%=================] Http Download\Uncompress

process stops here doesnt go any further. 

Please help me resolve this problem.

0 Kudos
124 Views
Yuri
NXP TechSupport
NXP TechSupport

@kenizgandhi 
Hello,

   Looks like default U-boot configuration (network boot) takes place
in the case. Please try to stop U-boot right after it starts and configure
U-boot environment for SD boot.

Regards,
Yuri.

0 Kudos
116 Views
kenizgandhi
Contributor III

@Yuri 

Hello,

 

I am unable to stop u-boot as it doesn’t accept any input from keyboard. That’s the main issue.

0 Kudos
103 Views
Yuri
NXP TechSupport
NXP TechSupport

@kenizgandhi 
Hello,

   I just tried the demo image "imx-image-multimedia-imx8mpevk.wic" of L5.10.9  (SD card).
All is working.

Regards,
Yuri.

View solution in original post

0 Kudos
151 Views
kenizgandhi
Contributor III

I think i changed the emmc device in uboot after that it doesnt boot. Can you please tell to get back to the booting process?

0 Kudos
149 Views
Yuri
NXP TechSupport
NXP TechSupport

@kenizgandhi 
Hello,

 

You may try to transfer the Linux demo image to Your board.

https://www.nxp.com/webapp/Download?colCode=L5.10.9_1.0.0_MX8MP&appType=license

Use instructions of the User's Guide.

https://www.nxp.com/docs/en/user-guide/IMX_LINUX_USERS_GUIDE.pdf


Summary Page:

https://www.nxp.com/design/software/embedded-software/i-mx-software/embedded-linux-for-i-mx-applicat...

  Note: The i.MX 8M Plus EVK board has one TF card slot. This slot uses the USDHC2 controller.
So, it is possible to prepare /write boot SD card, using demo .wic file.

Regards,
Yuri.

0 Kudos