Unable to play video in Media player from Morty Release

cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to play video in Media player from Morty Release

793 Views
balasubramaniya
Contributor II

Hi,

I am using the yocto Morty release and Linux 4.9 kernel.

When I run the sample video in Media player, I can able to hear the audio from the sample video but in display is black only appears till the video end.

But Media player from Krogoth release is working properly.

Is it a know issue or is there any patch is available to solve this issue.

Hope for the better guidance.

Best regards,

Bala

0 Kudos
3 Replies

196 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Bala,

Are you using the Morty Branch from the Community BSP or a BSP Release (i.e. 4.9.11_1.0.0)? Would you please give us more details of your setup, which image you are baking and for which board?

Also, what codecs are failing on your test?

Regards,

0 Kudos

196 Views
balasubramaniya
Contributor II

Hi,

I am using L4.9.11_1.0.0-ga_images_MX6QPDLSOLOX.tar.gz image for Quad SOM(Linux).

$ DISPLAY=:0 gtk-play --gst-debug-level=1 /media_files/test_play.mp4

(gtk-play:1046): Gtk-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionMa
nager was not provided by any .service files

====== AIUR: 4.2.1 build on Apr 17 2018 12:27:47. ======
        Core: MPEG4PARSER_06.12.07  build on May 16 2017 06:45:37
 file: /usr/lib/imx-mm/parser/lib_mp4_parser_arm11_elinux.so.3.2
------------------------
    Track 00 [video_0] Enabled
        Duration: 0:00:52.208000000
        Language: und
    Mime:
        video/x-h264, parsed=(boolean)true, alignment=(string)au, stream-format=(string)avc, width=(int)1920, height=(int)1080, framerate=(frac
tion)24/1, codec_data=(buffer)01640032ffe1001b67640032ac34e601e0089f961000000300100000030300f18319a001000668e9784cb22c
------------------------
display(/dev/fb0) resolution is (1920x1080).
====== OVERLAYSINK: 4.2.1 build on Apr 17 2018 12:27:52. ======
display(/dev/fb0) resolution is (1920x1080).
[INFO]  Product Info: i.MX6Q/D/S
[INFO]  Product Info: i.MX6Q/D/S
====== VPUDEC: 4.2.1 build on Apr 17 2018 12:27:53. ======
        wrapper: 1.0.68 (VPUWRAPPER_ARM_LINUX Build on Apr 11 2018 19:47:57)
        vpulib: 5.4.37
        firmware: 3.1.1.46072
[INFO]  bitstreamMode 1, chromaInterleave 1, mapType 0, tiled2LinearEnable 0
------------------------
    Track 01 [audio_0] Enabled
        Duration: 0:00:51.946000000
        Language: und
    Mime:
        audio/mpeg, mpegversion=(int)4, channels=(int)2, rate=(int)48000, bitrate=(int)0, stream-format=(string)raw, codec_data=(buffer)1190
------------------------

====== BEEP: 4.2.1 build on Apr 17 2018 12:27:48. ======
        Core: AAC decoder Wrapper  build on May 30 2016 12:33:44
 file: /usr/lib/imx-mm/audio-codec/wrap/lib_aacd_wrap_arm12_elinux.so.3
CODEC: BLN_MAD-MMCODECS_AACD_ARM_03.09.00_CORTEX-A8  build on Mar 15 2017 17:11:31.
display(/dev/fb0) resolution mxc_v4l2_output v4l2_out: Bypass IC.
is (1920x1080).
mxc_v4l2_output v4l2_out: Bypass IC.

Total showed frames (1252), display master blited (1252), playing for (0:00:52.212664000), fps (23.979).

Best regards,

Bala

0 Kudos

196 Views
lakshmishetty
Contributor II

Hi Bala,

Even I am facing the same issue in Linux4.9.51 kernel. While playing the video using Media player GUI app as well as using gtk-play and gplay-1.0 commands only audio is working. But video is not playing on LCD display.

Could you please suggest whether this issue is fixed?

Thanks,

Best Regards,

Lakshmi Hegde

0 Kudos