Udpsink "Internal data flow problem" on MX6

cancel
Showing results for 
Search instead for 
Did you mean: 

Udpsink "Internal data flow problem" on MX6

395 Views
RobbieJiang
Contributor IV

Hi,

I'm using the following gstreamer pipeline to stream H.264 video from MX6Q/Linux to PC.

gst-launch -v tvsrc device=/dev/video0 capture-mode=0 ! 'video/x-raw-yuv,format=(fourcc)UYVY,width=720,height=576,framerate=25/1' ! mfw_ipucsc ! 'video/x-raw-yuv,format=(fourcc)I420, width=720,height=576,framerate=25/1'! mfw_deinterlacer ! vpuenc codec=avc   gopsize=2 ! video/x-h264,width=720,height=576 ! rtph264pay mtu=1024 ! udpsink host=192.168.0.68 port=5004

At the end of the output message, I got:

"

WARNING: from element /GstPipeline:pipeline0/GstUDPSink:udpsink0: Internal data flow problem.

Additional debug info:

gstbasesink.c(3626): gst_base_sink_chain_unlocked (): /GstPipeline:pipeline0/GstUDPSink:udpsink0:

Received buffer without a new-segment. Assuming timestamps start from 0.

"

Although the receiver pipeline on host (192.168.0.68) can correctly receive, decode and display the live video,

I am still wondering what "udpsink0: Internal data flow problem" mean.

Is there anything wrong here?

What is the root cause of the udpsink "Internal data flow" problem?

And is it possible to fix it?

Regards,

Robbie

Labels (3)
0 Kudos
2 Replies

160 Views
joanxie
NXP TechSupport
NXP TechSupport

it seems sync issue, try to set sync=true to check if you can stop the warning.

0 Kudos

160 Views
RobbieJiang
Contributor IV

Setting udpsink property 'sync=false' resolved the problem.

The default value of sync property is 'true'.

Guanqiong, thanks for your hints.

0 Kudos