The media service of imx6

cancel
Showing results for 
Search instead for 
Did you mean: 

The media service of imx6

222 Views
Contributor IV

I want to play some music or movic by Qt. So first I use  QMediaPlayer to do that, it isn't working, with message:

 defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer" 

After that, I try using QSoundEffect to do. The result is still the same but with message:

PulseAudioService: pa_context_connect() failed

But when I used the test project from  /usr/share/qt5/examples/multimedia/imxplayer, it works well!!!

root@imx6qsabresd:/usr/share/qt5/examples/multimedia/imxplayer# ./imxplayer
** Message: GStreamer version 1.8.1
display(/dev/fb0) resolution is (1024x768).

Then I try running pulseaudio Individually on root:

W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).
E: [pulseaudio] module-console-kit.c: GetSessionsForUnixUser() call failed: org.freedesktop.DBus.Error.Spawn.PermissionsInvalid: The permission of the setuid helper is not correct
E: [pulseaudio] module.c: Failed to load module "module-console-kit" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

If it's on other normal user, just without the warning.

Then I try pulseaudio -vvvv, there is so much message but with the same error message.

I spent a lot of time asking questions between Qt forum and here.So could somebody please tell me how to fix it in detail?

Labels (1)
0 Kudos
1 Reply

45 Views
NXP TechSupport
NXP TechSupport

Hi 铭恒 李 

for building images with Qt one can follow attached Yocto Guide, use nxp linux from

linux-imx - i.MX Linux kernel 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos