System hang with no sign while display switching between HDMI and iPhone project to monitorne

cancel
Showing results for 
Search instead for 
Did you mean: 

System hang with no sign while display switching between HDMI and iPhone project to monitorne

Jump to solution
100 Views
Contributor II

Hi , 

My system is Android on i.MX6q + ADV7481 . Recently we found our system suddenly hang after few hours when switching display source from HDMI and iPhone project to monitor . ( Both playing videos) 

I only found there are few IPU warnings like 

imx-ipuv3 2800000.ipu: IPU Warning - IPU_INT_STAT_5 = 0x08000000

or 

imx-ipuv3 2400000.ipu: IPU Warning - IPU_INT_STAT_10 = 0x00000001

and these are NOT the last message before system hang . 

The display is totally black ( not output ?) while hang , and it seems not only not display is gone , but the whole system dead too . 

Anyone has similar experience can help or suggestion ? 

Thanks in advance . 

Best regards,

Sidney

Tags (1)
0 Kudos
1 Solution
NXP TechSupport
NXP TechSupport

Hi Sidney

for IPU IPU_INT_STAT warnings one can try to tweak QoS as described on

Set max prio for all Exchanges with IPU1 on AXI bus · wolfgar/utilite@61643d3 · GitHub 

sect.36.4.7 GPR (IOMUXC_GPR6) i.MX6DQ Reference Manual

i.MX 6Dual/6Quad Applications Processor Reference Manual 

If whole system hangs one can try to test memory

i.MX 6/7 DDR Stress Test Tool  

and check board power supplies, clock stabilities using

IMX6DQ6SDLHDG, Hardware Development Guide for i.MX 6Quad, 6Dual, 6DualLite, 6Solo Families of Applic...

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

7 Replies
Contributor II

Hi Igor , 

Thanks for quick reply . 

Now testing . Hope it works ! 

Best regards,

Sidney

0 Kudos
1 View
NXP TechSupport
NXP TechSupport

Hi Sidney

for IPU IPU_INT_STAT warnings one can try to tweak QoS as described on

Set max prio for all Exchanges with IPU1 on AXI bus · wolfgar/utilite@61643d3 · GitHub 

sect.36.4.7 GPR (IOMUXC_GPR6) i.MX6DQ Reference Manual

i.MX 6Dual/6Quad Applications Processor Reference Manual 

If whole system hangs one can try to test memory

i.MX 6/7 DDR Stress Test Tool  

and check board power supplies, clock stabilities using

IMX6DQ6SDLHDG, Hardware Development Guide for i.MX 6Quad, 6Dual, 6DualLite, 6Solo Families of Applic...

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

Contributor II

Hi igor ,

After the weekend testing , the symptom has changed . 

After few minutes or hours running , system reset after a series of 

imx-ipuv3 2800000.ipu: IPU Warning - IPU_INT_STAT_5 = 0x08000000

Any suggestion ? 

Best regards,

Sidney

0 Kudos
NXP TechSupport
NXP TechSupport

Hi Sidney

one can try dmfc=3 in kernel command line as in
https://community.nxp.com/message/953200?commentID=953200#comment-953200 

Best regards
igor

0 Kudos
Contributor II

Hi igor . 

I see. Thanks ! Test on going . 

BTW , may I ask , what does  "dmfc=3" really mean ?

Best regards,

Sidney

0 Kudos
NXP TechSupport
NXP TechSupport

it is described on p.8 attached document.

Best regards
igor

Contributor II

Thank you very much 

0 Kudos