Switch to LDO bypass mode issue for custom board of imx6dlsabresd

cancel
Showing results for 
Search instead for 
Did you mean: 

Switch to LDO bypass mode issue for custom board of imx6dlsabresd

1,205 Views
bandarulavanya
Contributor V

Hi All,

I am trying to port kernel and u boot in yocto kernel version is 3.14 and u boot version is 2014, i got up to below log

                                                                               
U-Boot 2014.04 (Jun 23 2016 - 15:11:49)                                       

CPU:   Freescale i.MX6SOLO rev1.3 at 792 MHz

CPU:   Temperature 31 C, calibration data: 0x5cb54a5f

Reset cause: POR

Board: MX6-SabreSD

I2C:   ready

DRAM:  512 MiB

MMC:   FSL_SDHC: 0, FSL_SDHC: 1, FSL_SDHC: 2

*** Warning - bad CRC, using default environment

No panel detected: default to Hannstar-XGA

Display: Hannstar-XGA (1024x768)

In:serial

Out:   serial

Err:   serial

Found PFUZE100 deviceid=10,revid=21

mmc1 is current device

Net:   Phy not found

PHY reset timed out

FEC [PRIME]

Normal Boot

Hit any key to stop autoboot:  0

mmc1 is current device

reading boot.scr

** Unable to read file boot.scr **

reading zImage

5930360 bytes read in 278 ms (20.3 MiB/s)

Booting from mmc ...

reading imx6_fs_wcam.dtb

42468 bytes read in 19 ms (2.1 MiB/s)

Kernel image @ 0x12000000 [ 0x000000 - 0x5a7d78 ]

## Flattened Device Tree blob at 18000000

   Booting using the fdt blob at 0x18000000

   Using Device Tree in place at 18000000, end 1800d5e3

switch to ldo_bypass mode!

Starting kernel ...

After Starting kernel it was hanged.  How to switch to ldo_bypass mode .

In my older versions of u boot we used

#define CONFIG_IMX6_INTER_LDO_BYPASS 0

But in new versions what i need to do to boot the kernel .

If anyone knows kindly help me to sort it out.

Thanks & Regards,

Lavanya

0 Kudos
2 Replies

278 Views
art
NXP TechSupport
NXP TechSupport

The issue seems to be related not with the LDO modes (the i.MX6 SABRE board also switches to the LDO bypass mode but then works fine), but with some DRAM problems, e.g. wrong memory size configuration in software or bad PCB footprint/routing (in that case, when the intensive DRAM data exchange begins during the kernel start, the DRAM crash may occur in case of wrong PCB routing). Please check.


Have a great day,
Artur

0 Kudos

278 Views
veeranjaneyulug
Contributor III

Hi Lavanya

we solve that issue but we are not succeed for custom board bring up.we are using yocto setup version 1.7 ,kernle version 3.14.28 ,u-boot version 2014,

In u-boot we customized as per our board ddr settings and all.u-boot is booting captured logs.

we moved to imx6_fs_wcam-ldo.dtb to imx6_fs_wcam.dtb file .then we solve that ldo-bypass mode issue.Then kernel not booting .

logs are mentioned blow

U-Boot 2014.04 (Jun 27 2016 - 18:48:53)

CPU:   Freescale i.MX6SOLO rev1.3 at 792 MHz

CPU:   Temperature 33 C, calibration data: 0x5cb54a5f

Reset cause: POR

Board: MX6-SabreSD

I2C:   ready

DRAM:  512 MiB

MMC:   FSL_SDHC: 0, FSL_SDHC: 1, FSL_SDHC: 2

No panel detected: default to Hannstar-XGA

Display: Hannstar-XGA (1024x768)

In:    serial

Out:   serial

Err:   serial

Found PFUZE100 deviceid=10,revid=21

mmc1 is current device

Net:   Phy not found

PHY reset timed out

FEC [PRIME]

Normal Boot

Hit any key to stop autoboot:  0

mmc1 is current device

reading boot.scr

** Unable to read file boot.scr **

reading zImage

5931000 bytes read in 281 ms (20.1 MiB/s)

Booting from mmc ...

reading imx6-fs-wcam-ldo.dtb

** Unable to read file imx6-fs-wcam-ldo.dtb **

Kernel image @ 0x10008000 [ 0x000000 - 0x5a7ff8 ]

No gpc device node -9, force to ldo-enable.

Starting kernel ...

Then kernel not booting.

any one solve this issue can u share me.

Awaiting for valuable suggestion

please can any body solve this issue.

Thanks & Regards

veeranjaneyulu

0 Kudos