Station mode is not working for R8188EU Wi-Fi Dongle

cancel
Showing results for 
Search instead for 
Did you mean: 

Station mode is not working for R8188EU Wi-Fi Dongle

Jump to solution
115 Views
sanketparekh
Contributor II

Hi,

I am using R8188EU driver for  Wi-FI dongle(TL-WN725N V3) interfaced with IMX6DL processor via USB.

AP mode is working fine. Station mode is not working on my set-up.

Linux Kernel version: 4.1.15

Kernel configuration

CONFIG_R8188EU=m
CONFIG_88EU_AP_MODE=y

Please give me the detailed steps to configure the station mode for R8188EU Wi-Fi dongle.

Thanks & Regards.

Sanket Parekh

Labels (1)
0 Kudos
1 Solution
72 Views
weidong_sun
NXP TechSupport
NXP TechSupport

Hi,

Try the following way, please!

......

in driver path, you can find include subdirectory, enter it, and open autoconf.h, add one line to start AP + STA mode:


#define CONFIG_CONCURRENT_MODE
#ifdef CONFIG_CONCURRENT_MODE
#define CONFIG_RUNTIME_PORT_SWITCH

#define CONFIG_TSF_RESET_OFFLOAD /* For 2 PORT TSF SYNC. */
#endif

If the way can't help you start ap+sta mode, you had better contact provider.

 

Have a nice day!

B.R,

weidong

 

View solution in original post

0 Kudos
2 Replies
73 Views
weidong_sun
NXP TechSupport
NXP TechSupport

Hi,

Try the following way, please!

......

in driver path, you can find include subdirectory, enter it, and open autoconf.h, add one line to start AP + STA mode:


#define CONFIG_CONCURRENT_MODE
#ifdef CONFIG_CONCURRENT_MODE
#define CONFIG_RUNTIME_PORT_SWITCH

#define CONFIG_TSF_RESET_OFFLOAD /* For 2 PORT TSF SYNC. */
#endif

If the way can't help you start ap+sta mode, you had better contact provider.

 

Have a nice day!

B.R,

weidong

 

View solution in original post

0 Kudos
95 Views
sanketparekh
Contributor II

Hi,

With the help of command "wpa_supplicant -B -iwlan0 -Dwext -c/etc/wpa_supplicant.conf" STA mode is working fine.

Now I am facing one more issue that is AP and station mode is working fine individually. But i need to run AP and station mode is in simultaneous manner. It is not working for now. Reason behind is for AP and STA mode i have single phy interface that is "wlan0". That's why simultaneous operation is not working.

Can you please help me to create wlan0 and wlan1 for AP and STA mode?

What I need to do with RTL8188EU driver for the same?

Thanks & Regards.

Sanket Parekh

 

0 Kudos