[SGTL5000] SGTL5000 in I2S slave mode

cancel
Showing results for 
Search instead for 
Did you mean: 

[SGTL5000] SGTL5000 in I2S slave mode

1,732 Views
castel
Contributor III

For some reason, we need to use SGTL5000 DAC in I2S mode.

In my environment, fs=48khz, mclk=256fs=12.288Mhz, sck=64fs=3.072Mhz. VDDIO=VDDA=3.3V, VDDD=1.2V.

We set SGTL5000 in slave mode and SYS_FS=48k, MCLK_FREQ=256fs.

But no audio output.

(Same power supply was ok by using SGTL5000 in master mode by iMX6 driver,

but we change mclk to 12.288 , and using slave mode, no audio come out)

Anyone have the successful to use SGTL5000 in slave mode,

and can give us the setting sequence of I2C command ?

Or can some one can tell me how to debug by some I2C command ?

My SGTL5000 version is 0X11.

Labels (3)
0 Kudos
4 Replies

642 Views
igorpadykov
NXP TechSupport
NXP TechSupport

HI Kang

one can look at patch below

[alsa-devel] No sound captured with SGTL5000 on i.MX6 in I²S master mode

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos

642 Views
fabio_estevam
NXP Employee
NXP Employee

Yes, applying the equivalent patch that Igor pointed out should fix the issue.

Which kernel version are you trying?

Regards,

Fabio Estevam

0 Kudos

642 Views
castel
Contributor III

Hi Igor,

Could you help to get the setting sequence of SGTL5000 to slave mode?
The Linux driver only support the codec in master mode.

Thanks,

0 Kudos

642 Views
igorpadykov
NXP TechSupport
NXP TechSupport

HI Kang

for configuring SGTL5000 to slave mode

please set register CHIP_I2S_CTRL 0x0006 bit MS=0x0 = Slave

Best regards

igor

0 Kudos