Running GUI on Wayland backend wih Yocto imx-image-core build?

cancel
Showing results for 
Search instead for 
Did you mean: 

Running GUI on Wayland backend wih Yocto imx-image-core build?

458 Views
tony-atlismv
Contributor III

I would like to know if the Yocto build imx-image-core includes a windowing GUI interface on the Wayland backend? According to the latest version of the iMX Yocto Project User's Guide (L5.4.24_2.1.0), it states for the imx-image-core "An i.MX image with i.MX test applications to be used for Wayland backends. This image is used by our daily core testing," but doesn't state if it includes a windowing GUI interface? I am using a imx8qm mek board for development and noticed when I ran the imx-image-core from the SD card, I see the Linux Penguins display, then the Open Embedded splash screen, but nothing displayed after that.

If the imx-image-core does not include a windowing GUI interface, can I build and run a Gnome or KDE GUI windowing interface using the Yocto imx-image-core build? Or, is there windowing GUI interface available to the imx-image-core build, but just needs to be added to the Yocto local.conf file? What would be the procedure to add this windowing GUI interface to the build in the Yocto local.conf file?

Note, I am using the imx-image-core since I want a very minimalistic image to test iMX8 performance with a few isolated programs.

Thanks, Tony S.

0 Kudos
2 Replies

447 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello Tony,

The core-image-minimal includes a basic GUI, but if you want to run QT and other interfaces you need the imx-full-image.

Regards

 

0 Kudos

440 Views
tony-atlismv
Contributor III

Hi,

Thanks for the reply and letting me know there is a GUI available on the imx-image-core. Unfortunately, I am not able to see the GUI come up though. I have built the imx-image-core with all of the Qt libraries and tools, so that part does work from the ttyUSB0 command line. But, in the BSP L5.4.24_2.1.0, there is no imx-image-core to test with and compare against. Only the imx-imag-full and imx-image-multimedia images are there. 

Any suggestions to try in order to resolve the GUI not coming up after the Open Embedded splash screen? For now, I'm going to try a bare build of the imx-image-core without anything added to see if the GUI does come up.

Regards

0 Kudos