Replace the old kernel by the new compiled one (urgent)

cancel
Showing results for 
Search instead for 
Did you mean: 

Replace the old kernel by the new compiled one (urgent)

201 Views
mohamad-ahmad
Contributor III

Hello,

It is my first exprience in the compilation of the kernel - Custom kernel, mainly the compilation on the sabre lite imx6 board.

My compilation is done on the board directly without cross compilation,

I have tried the Commands after (make) -> make install -> make modules_install, also i have tried the compilation in another way using this command make deb-pkg LOCALVERSION=-XXXXX KDEB_PKGVERSION=1, but the system is always working on the old one.

its a problem of bootloader!!!!

I don't know about the existing bootloader in the debian jessie distribution (https://boundarydevices.com/debian-8-3-jessie-for-i-mx6-boards-february-2016-kernel-3-14-28/) and i couldn't find neither grub bootloader nor lilo.

thanks for the help,

Mohamad

Labels (2)
1 Reply

77 Views
gary_bisson
Senior Contributor III

Hi Mohamad,

This is not a bootloader issue, as a FYI the bootloader we are using is U-Boot. Grub and Lilo are usually used for x86 platforms, not ARM.

Here is a procedure you need to follow in order to update the kernel in our Ubuntu/Debian images:

https://boundarydevices.com/ubuntunizing-i-mx6-kernels/

Regards,

Gary