RT1021: Connecting to external SDRAM with Segger J-Link

cancel
Showing results for 
Search instead for 
Did you mean: 

RT1021: Connecting to external SDRAM with Segger J-Link

Jump to solution
283 Views
rshipman
Contributor V

Hi,

I have just started using a Segger J-Link Ultra+ with MCUXpresso and I am unable to debug code that is running on the RT1021 using external SDRAM. I just get 0xdeadbeee in the debug call stack.

If I use a project that runs entirely in internal SRAM, the debugger seems to work ok.

Up until now I have been using an LPC-Link2 debugger, using the MCUXpresso LinkServer CMSIS-DAP option to debug. I have a .scp script to initialise the SDRAM which works fine.

I believe the J-Link problem is because the SDRAM has not been initialised and I need a J-Link script to do this.

If it is a J-Link script that I need, do you have an example that would initialise the SDRAM in the same way as the .scp one please? Perhaps you have one for the RT1020-EVK? That would be perfect if you do.

Any information would be very helpful.

Thanks and regards,

Ronnie

 

Labels (1)
0 Kudos
1 Solution
275 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi @rshipman ,

   JLINK+MCUXpresso+SDRAM, need to use the .jlinkscript file to enable the SEMC for the SDRAM.

 Please open the SDK demo code, it already contains the script file:

\SDK_2_12_0_EVK-MIMXRT1020\boards\evkmimxrt1020\demo_apps\hello_world

kerryzhou_0-1661145038832.png

Then in the mcuxpresso debug configurations, add the related script file is OK.

 

Wish it helps you!

Best Regards,

Kerry

 

View solution in original post

2 Replies
272 Views
rshipman
Contributor V

Hi Kerry,

Many thanks for your prompt reply!

Ronnie

0 Kudos
276 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi @rshipman ,

   JLINK+MCUXpresso+SDRAM, need to use the .jlinkscript file to enable the SEMC for the SDRAM.

 Please open the SDK demo code, it already contains the script file:

\SDK_2_12_0_EVK-MIMXRT1020\boards\evkmimxrt1020\demo_apps\hello_world

kerryzhou_0-1661145038832.png

Then in the mcuxpresso debug configurations, add the related script file is OK.

 

Wish it helps you!

Best Regards,

Kerry