QtQuick.Extras is missing: Yocto & Qt5 on imx6 solox sdb

cancel
Showing results for 
Search instead for 
Did you mean: 

QtQuick.Extras is missing: Yocto & Qt5 on imx6 solox sdb

4,607 Views
anjaunnasch
Contributor II

Hello. i have a problem with my qt5 application. i want to run the example dashboard on imx6 solox sdb and it tells me:

qrc:/qml/dashboard.qml:45 module "QtQuick.Extras" is not installed

qtquick.controls & everything else works, but not extras.

in my local.conf i added the following:

IMAGE_INSTALL_append = " gcc g++ binutils libgcc libgcc-dev libstdc++ libstdc++-dev libstdc++-staticdev \

autoconf automake ccache chkconfig glib-networking glibmm \

packagegroup-core-buildessential pkgconfig  \

boost cmake zlib glib-2.0 packagegroup-fsl-tools-testapps  \

    ruby \

    cpufrequtils \

    nano \

    gdb \

    gstreamer \

    gst-meta-video \

    gst-fsl-plugin \

    gst-plugins-base-app \

    gst-plugins-base \

    gst-plugins-good \

    gst-plugins-good-rtsp \

    gst-plugins-good-udp \

    gst-plugins-good-rtpmanager \

    gst-plugins-good-rtp \

    gst-plugins-good-video4linux2 \

    openssh-sftp-server \

    packagegroup-fsl-gstreamer \

    packagegroup-fsl-tools-testapps \

    packagegroup-fsl-tools-benchmark \

    imx-vpu \

    imx-test \  

    qtbase-fonts \

    qtbase-plugins \

    qtbase-tools \

    qtbase-examples \

    qtdeclarative \

    qtdeclarative-plugins \

    qtdeclarative-tools \

    qtdeclarative-examples \

    qtdeclarative-qmlplugins \

    qtmultimedia \

    qtmultimedia-plugins \

    qtmultimedia-examples \

    qtmultimedia-qmlplugins \

    qtsvg \

    qtsvg-plugins \

    qtsensors \

    qtsensors-plugins \

    qtsensors-qmlplugins \

    qtimageformats-plugins \

    qtsystems \

    qtsystems-tools \

    qtsystems-examples \

    qtsystems-qmlplugins \

    qtscript \

    qtgraphicaleffects-qmlplugins \

    qtconnectivity \

    qtconnectivity-qmlplugins \

    qtlocation \

    qtlocation-plugins \

    qtlocation-qmlplugins \

    qtlocation-examples \

    cinematicexperience \

    cairo pango fontconfig freetype pulseaudio dbus \

    alsa-lib alsa-tools alsa-state alsa-utils-alsaconf fsl-alsa-plugins \

    i2c-tools \

    qtquickcontrols-qmlplugins \

    qtquick1 \

    qtscript \

    "

PACKAGECONFIG_append_pn-qtbase = " accessibility"

PACKAGECONFIG_append_pn-qtquickcontrols = " accessibility"

but when i take a look at my bitbaked filesystem in /usr/lib/qt5/qml/QtQuick

i have Controls, Dialogs, layouts, localstorage, particles.2, privatWidgets, window.2 and XmlListModel

(no extras)

compared to my build qt-toolchain in  /opt/poky/1.6.2/sysroots/cortexa9hf-vfp-neon-poky-linux-gnueabi/usr/lib/qt5/qml/QtQuick

it contains the folder extras

so what can i do to solve this problem?

Labels (3)
0 Kudos
4 Replies

888 Views
ankurkumarsatas
Contributor II

You have to update your qt version to 5.5 or higher. I also had the same problem and then I updated qt version to 5.6 and application was running.

Please have a look this link qt5.6 on imx

Let us know if you still have problem compiling qt 5.6

888 Views
almarto
Contributor IV

Thank you very much for your help! I was able to solve this problem some time ago by doing what your suggest.

I have not seen your comment until now ... so thank you for your feedback!

0 Kudos

888 Views
almarto
Contributor IV

Hi Anja,

I have the exactly the same problem as you, although I am working with imx6ulevk. Have you already found a solution?

I have been trying to solve it for the last week and I can summarize what I have done so far:

I first began by creating fsl-image-qt5 which supports Qt5.4.3, as QtQuickExtras only runs from Qt5.5 I decided to leave the official fsl release and rely on the community bsp.

Now I am working with jethro branch, since qt5 is upgraded to 5.5 (5.6 in master branch) and I am trying to go on like this.

I am just trying to make sure that I clone the right branch in the sources/meta-qt5 folder and I am bitbaking (by trial and error) different configurations in local.conf.

I will come back to the thread with comment in case I am able to solve this issue.

Please let me know if you find a solution.

BR

alvaro

0 Kudos

888 Views
CarlosCasillas
NXP Employee
NXP Employee

Hi Anja,

I’m afraid that Freescale does not support QT code, and can only work on bug fixes in GPU package if the error is narrowed down to GPU code.

Best regards!

/Carlos

0 Kudos