Problems with yocto repo sync for sabresd platform.

cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with yocto repo sync for sabresd platform.

2,501 Views
gaun
Contributor II

Hi,

I am trying to use yocto for the sabresd platform. I am behind a corporate firewall and can use git over http only. In the Freescale Yocto project users guide in the "Yocto Project Setup"  I have done the following:

repo init -u  http://git.freescale.com/git/cgit.cgi/imx/fsl-arm-yocto-bsp.git -b  imx-3.14.52-1.1.0_ga

repo syc

I have modified the manifest file to include http instead of git links. It is as follows:

  <remote fetch="http://git.freescale.com/git/cgit.cgi/imx" name="fsl-release" />

  <remote fetch="http://git.yoctoproject.org/git" name="yocto"/>

  <remote fetch="https://github.com/Freescale" name="freescale"/>

  <remote fetch="https://github.com/openembedded" name="oe"/>

  <remote fetch="https://github.com/OSSystems" name="OSSystems"/>

  <remote fetch="https://github.com/meta-qt5"  name="QT5"/>

Can somebody please review the above edit? I get the following error:

Fetching projects:  33% (3/9)  Fetching project meta-fsl-bsp-release

...

...

fatal: http://git.freescale.com/git/cgit.cgi/imx/meta-fsl-bsp-release/info/refs not valid: is this a git repository?

fatal: http://git.freescale.com/git/cgit.cgi/imx/meta-fsl-bsp-release/info/refs not valid: is this a git repository?

error: Cannot fetch meta-fsl-bsp-release.18 MiB | 58.00 KiB/s  

Labels (1)
8 Replies

716 Views
samkunun
Contributor II

Hi,

Sorry to dig old thread.

I have same problem as Gautam.

Usually the info/refs is under <repository_name_without_dot_git>/info/refs, for example :

http://git.yoctoproject.org/cgit/cgit.cgi/meta-fsl-arm/info/refs

But somehow, for freescale git repository, it is under <repository_name_with_dot_git>/info/refs, like this :

http://git.freescale.com/git/cgit.cgi/imx/meta-fsl-bsp-release.git/info/refs

Please take notice the dot git

Workarounds that strange but works for me, add ".git" to the repository name, like below :

  <project remote="fsl-release" name="meta-fsl-bsp-release.git" path="sources/meta-fsl-bsp-release" revision="jethro_4.1.15-1.0.0_ga" >

     <copyfile src="imx/tools/fsl-setup-release.sh" dest="fsl-setup-release.sh"/>

  </project>

  <project remote="fsl-release" revision="jethro" name="meta-nxp-agl.git" path="sources/meta-nxp-agl">

      <copyfile src="tools/nxp-setup-agl.sh" dest="nxp-setup-agl.sh"/>

  </project>

And do :

$ repo sync --force-sync sources/meta-fsl-bsp-release

$ repo sync --force-sync sources/meta-nxp-agl

Hope it helps.

Thank you.

Regards,

--sk

716 Views
karina_valencia
NXP Apps Support
NXP Apps Support

jimmychan​ can you  help to continue with the follow up?

0 Kudos

716 Views
jimmychan
NXP TechSupport
NXP TechSupport

You may ask your IT dept about the proxy setting and the port number that can be used so that you can 'git' the link.

0 Kudos

716 Views
gaun
Contributor II

Jimmy Chan,

I think you did not understand the question. Due the limitations with the git port  I had to use http to 'git' the link. What I am expecting is somebody to verify if the above 'http' links are correct for cloning.

I think there is a problem with the git setup from your side. You can replicate the same steps as above to get the problem. I have attached the manifest.xml file reference.

-Gautam.

0 Kudos

716 Views
rameshbabup
NXP Employee
NXP Employee

Gautam,

Did you get it working?

0 Kudos

716 Views
gaun
Contributor II

Ramesh,

  I am not able to get it working with the same setup. Any chance someone from your end can try it out or review the xml file attached. It is a very simple solution from your end.

Thanks,

Gautam.

0 Kudos

716 Views
jimmychan
NXP TechSupport
NXP TechSupport
0 Kudos

716 Views
gaun
Contributor II

Let me check that and get back to you. It might take some time as I am tied up with something else.

0 Kudos