Out-of-tree galcore build causing Qt seg fault

cancel
Showing results for 
Search instead for 
Did you mean: 

Out-of-tree galcore build causing Qt seg fault

337 Views
joerutledge
Contributor III

Hi. I use Yocto to build my imx6 images and toolchains, however it's a bit heavy and slow for working on kernel drivers. As such my dev cycle is to build the kernel on its own, just using the output of a "do_patch" run in yocto as the source tree base and sourcing the toolchain environment.

This is normally not a problem, as mostly I'm focussed at that end of the s/w stack. However, I now need to be able to run a Qt application (running under eglfs) on top of my continually updated kernel. To do this, I need the imx6 graphics driver working, so I get the galcore source from git://github.com/Freescale/kernel-module-imx-gpu-viv.git export my kernel build directory, make it and deploy it. That module loads perfectly. However running the working application that has already been built with Yocto causes a crash, somewhere in libQt5EglDeviceIntegration.so.5

What do I need to do to make this work? Is there some part of Qt tied to the graphics driver that's going to force me to rebuild the entire library? What's the relationship between galcore.ko and Qt? Is there now a weird dependency between my application and the linux kernel?!

0 Kudos
2 Replies

157 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hi joerutledge,

This is huge effort you are development, regards

0 Kudos

157 Views
joerutledge
Contributor III

PEBCAK. I'm an idiot. I didn't check out from the right SHA1 (that listed in the recipe) for the galcore driver.

0 Kudos