Our project need a video player on i.MX6 ubuntu,to decode H263/MP3 video clip. But gplay failed to decode MP3 audio.

cancel
Showing results for 
Search instead for 
Did you mean: 

Our project need a video player on i.MX6 ubuntu,to decode H263/MP3 video clip. But gplay failed to decode MP3 audio.

463 Views
franklee19731
Contributor I

Either gplay or gst-launch can not decode MP3 audio in the clip.

In the info that gplay printed, there is a line:

no decoder available for type 'audio/mpeg, mpegversion(int)1, mpegaudioversion=(int)1, layer=(int)3, rate=(int)44100, channels=(int)2, parsed=(boolean)true'

The codec version is 3.0.7, I have tied 3.0.1 with the same video clip,  both video and audio can be decoded, audio is perfect but the video come out one frame every second.

MP3 audio is very common for us, and I notice there is a plugin ffdec_mp3 can decode mp3 audio. Can anyone tell me how to decode h263/mp3 clip smoothly on iMX6 ubuntu platform.

Labels (3)
0 Kudos
7 Replies

111 Views
SergioSolis
NXP Employee
NXP Employee

Let me try that video in our SABRE SDP.  What board are you using to test this?... have you tried Totem player?

0 Kudos

111 Views
xiaoqianlin
NXP Employee
NXP Employee

I tested this video clips on MX6DL board with bsp version 3.0.7, there is no sound output

Linda Lin
0 Kudos

111 Views
LyonWang
NXP Employee
NXP Employee

I tested on my 6q board with 3.0.7 codec, seems it works fine.

Could you provide some more details about this clip play.

enable the debug environment :  export GST_DEBUG=GST_ELEMENT_FACTORY:3,aiurdemux:3,beepdec:3

and post the log file to see the detail information about it

0 Kudos

111 Views
xiaoqianlin
NXP Employee
NXP Employee

We tested this issue with BSP 3.0.7+Linux_V4.1_ubuntu_with_hf .

Linda Lin
0 Kudos

111 Views
LyonWang
NXP Employee
NXP Employee

Hi, Linda,

    The root cause of this issue is that the ffdec mp3 plugin's RANK is default set to GST_RANK_NONE(0)

    Please use the attached ffmpeg plugin library to replace the origin one in /usr/lib/gstreamer-0.10.

    It could solve the issue.

Thanks

Lyon

0 Kudos

111 Views
franklee19731
Contributor I

Hi  Lyon:

   Thanks, this problem is solved when I apply the new ffmpeg plugin you provided.

   And thank you all that help me to trace this problem!

Frank

0 Kudos

111 Views
franklee19731
Contributor I

I use board design by our team, but it was derived from Sabresd.

I just use Totem player, it can not play audio of the clip too.

0 Kudos