OpenCV 3.1 for i.MX7

cancel
Showing results for 
Search instead for 
Did you mean: 

OpenCV 3.1 for i.MX7

398 Views
arisinisalo
Contributor I

I am trying to build an image using Yocto that would contain OpenCV 3.1. Is there any ready solution/receipe for this?

Labels (3)
0 Kudos
1 Reply

105 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Ari Sinisalo,

You may search through the available recipes in Yocto by using the following command:

bitbake -s | grep opencv

There is a package for opencv (and opencv-samples) but in the L4.1.15 BSP Release this is version 2.4.

The Krogoth branch from the Community BSP does support OpenCV 3.1.

You may add the support for more recent OpenCV versions manually though. There are some documents on the communities that may be of help, such as the following:

https://community.nxp.com/docs/DOC-95396

Regards,

0 Kudos