Only software rasterizer in X11 on L3.0.35_1.1.0

cancel
Showing results for 
Search instead for 
Did you mean: 

Only software rasterizer in X11 on L3.0.35_1.1.0

771 Views
MartinScherer
Contributor I

Hello,

 

I have got a SABRE Lite board and I installed the L3.0.35_1.1.0 U-Boot, kernel and Ubuntu RFS on this system. I want to use OpenGL hardware acceleration in X11. The output of /var/log/Xorg.0.log looks as it should be according to your guidelines. /etc/X11/xorg.conf is also setup as required. However, when I run glxinfo, the output is as follows:

 

OpenGL vendor string: Mesa Project

OpenGL renderer string: Software Rasterizer

OpenGL version string: 2.1 Mesa 7.11

OpenGL shading language version string: 1.20

 

Furthermore, all OpenGL applications are running very slowly. What could be the problem? Please find the log and and configuration files attached.

 

Thanks in advance,

Martin Scherer


Original Attachment has been moved to: xorg.conf.zip

Original Attachment has been moved to: dmesg.txt.zip

Original Attachment has been moved to: Xorg.0.log.zip

Original Attachment has been moved to: glxinfo.txt.zip

Labels (3)
3 Replies

106 Views
mtx512
Contributor V

I have same issue, any news on how it should be configured. The "Linux Multimedia Framework User Guide" covers the video/audio side. From what I understand the Ubuntu RFS should include the neccesaary Vivante drivers for X11.

0 Kudos

106 Views
MartinScherer
Contributor I

This is also my understanding. I can definitely say, that the deb-package gpu-viv that is mentioned in the user guide is installed on my system.

0 Kudos

106 Views
jimmychan
NXP TechSupport
NXP TechSupport

I think you need to install the .deb files for the ubuntu.

Attached is the Linux_Multimedia_Framework_User_Guide.pdf.

You will find the information in it for installing .deb files for i.MX.

Please try it.