On board, In uboot I'm not able to type anything

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

On board, In uboot I'm not able to type anything

655 Views
aravinthkumarja
Senior Contributor II

Hi All,

I'm using Android 9 on iMX6q sabresd, on board In uboot I'm not able to enter/type anything. It's not taking my input. How to debug and fix this issue.

 

Labels (5)
Tags (3)
0 Kudos
3 Replies

620 Views
Harvey021
NXP TechSupport
NXP TechSupport

Hello,

At the end of the booting, I just spot the error "Bad Linux ARM64 Image magic!" which may happen when wrong kernel version used with uboot.

As with Linux 4.14.98 Kernel, please check if there is respective uboot.

 

Best Regards

Harvey

0 Kudos

643 Views
Harvey021
NXP TechSupport
NXP TechSupport

Hello aravinthkumarja.

This could be various ways of causing this problem.

Can you please firstly share what steps you have taken for downloading image and what images you have downloaded? 

And It would be better to check terminal settings and drivers related to your input devices.

 

Best regards

Harvey

0 Kudos

632 Views
laulavanya
Contributor II

Hi ,

Currently using the Android P9.0.0_2.2.0(Linux 4.14.98 Kernel) downloaded from Nxp

Its a Custom board with reference of sabresd MX6Q,Built and flashed the board using the sdcard .

During flashing facing below issue

U-Boot 2018.03-dirty (Mar 11 2022 - 00:08:57 +0530)

 

CPU: Freescale i.MX6Q rev1.3 at 792MHz
CPU: Industrial temperature grade (-40C to 105C) at 32C
Reset cause: POR
Model: i.MX6 Dual Console UI Board(PFUZE100)
Board: MX6Q-CONSOLEUI
DRAM: 2 GiB

 

board_initPMIC: PFUZE100! DEV_ID=0x10 REV_ID=0x21
power_init_board device ===
Fû?ÀR?MMC: FSL_SDHC: 0, FSL_SDHC: 1
Loading Environment from MMC... OK
No panel detected: default to Hannstar-XGA
Display: Hannstar-XGA (1024x768)
In: serial
Out: serial
Err: serial
flash target is MMC:1
Fastboot: Normal
Normal Boot
Hit any key to stop autoboot: 0
Bad Linux ARM64 Image magic!
=>

0 Kudos