OV5640 mipi driver probe fail [Urgent]

cancel
Showing results for 
Search instead for 
Did you mean: 

OV5640 mipi driver probe fail [Urgent]

764 Views
anjojohn
Contributor IV

Hi All

i am doing a bringup of ov5640-mipi camera with imx6dualite in custom board. The ov5640 driver probe fail to read the chip id. By using MSO found that the driver is not doing any activity in i2c-0 lines. both SDA and SCL are in high state. But the i2cdetect works and it gave me an device id of 0x44, Which is odd since the ov5640 address is 0x3c.

Could anyone help me why i2cdetect is able to drive the i2c line and ov5640-mipi driver can't. I can't doubt pin-muxing in dtb since i2cdetect is working.

Any help is appreciated

OV5640 is connected to i2c-0 alone, no other devices are connected.

Labels (4)
0 Kudos
2 Replies

220 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi anjo

this may be debugged using Chapter 19 OmniVision Camera Driver

attached Linux Manual and AN4553 Using Open Source Debugging Tools for Linux on i.MX.

http://www.nxp.com/assets/documents/data/en/application-notes/AN4553.pdf 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

220 Views
anjojohn
Contributor IV

Sorry for late reply. issue was due to hardware power-up sequence mismatch. hardware rework fixed the issue

0 Kudos