No serial console login prompt after kernel boots.

cancel
Showing results for 
Search instead for 
Did you mean: 

No serial console login prompt after kernel boots.

Jump to solution
7,430 Views
RandyGraham
Contributor IV

Hello,

I have built a linux 3.7-rc1 kernel and file system using buildroot for my mx28evk board, and the kernel seems to load and boot successfully.

However, I never get a login prompt at the serial console :

[3.700000]  host=freescale, domain=, nis-domain=(none)
[3.700000]  bootserver=192.168.0.28, rootserver=192.168.0.28, rootpath=
[3.710000] ALSA device list:
[3.710000]   #0: mxs_sgtl5000
[5.750000] VFS: Mounted root (nfs filesystem) on device 0:11.
[5.750000] Freeing init memory: 136K

Starting logging: OK

Starting rsyslog daemon: OK

Starting network...

ip: RTNETLINK answers: File exists


Normally at this point I would expect to see a login prompt, but I am seeing nothing.


I am using buildroot to build everything and believe I have set everything to configure a serial console on ttyAMA0 .


Has anyone run into this and give me some hints as to what I might look at to get a serial console login prompt working ?


Thanks for any help.


-Randy


Labels (2)
1 Solution
1,801 Views
OtavioSalvador
Senior Contributor II

The reason of it not working is due the change of ttyAM to ttyAMA device.

The FSL kernel uses ttyAM and mainline ttyAMA.

At Yocto we patch the FSL kernel to avoid this difference and always use ttyAMA

You can check it at meta-fsl-arm - Layer containing Freescale ARM hardware support metadata

View solution in original post

0 Kudos
8 Replies
1,802 Views
OtavioSalvador
Senior Contributor II

The reason of it not working is due the change of ttyAM to ttyAMA device.

The FSL kernel uses ttyAM and mainline ttyAMA.

At Yocto we patch the FSL kernel to avoid this difference and always use ttyAMA

You can check it at meta-fsl-arm - Layer containing Freescale ARM hardware support metadata

0 Kudos
1,801 Views
RandyGraham
Contributor IV

Thanks Otavio.

Yes, I am aware of this and should have mentioned that I am using the mainline kernel, so ttyAMA0 should be correct.

1,801 Views
JasonLiu
NXP Employee
NXP Employee

Could you please post your kernel boot command line?

0 Kudos
1,801 Views
RandyGraham
Contributor IV

Hi Hui, thanks for replying so quickly.

Here is the relevant line from my inittab:

ttyAMA0::respawn:/sbin/getty -L ttyAMA0 115200 vt100 # GENERIC_SERIAL

I don't have the complete boot command line in front of me, but I definitely have 'console=ttyAMA0' specified on it.

Also, if I replace the inittab line above with '::respawn:/bin/sh' I do get a device console without login prompt.

Ideally, I want a proper serial console.

Thanks again for your help, I can post the exact boot command line I am using later today.

-Randy

0 Kudos
1,801 Views
RandyGraham
Contributor IV

Here are my bootargs:bootargs=console=ttyAMA0,115200n8 ip=192.168.0.99:192.168.0.28:192.168.0.1:255.255.255.0:freescale:eth0:off root=/dev/nfs rw nfsroot=192.168.0.28:/tools/rootfs

0 Kudos
1,801 Views
RandyGraham
Contributor IV

This was caused by my error, I was mounting the rootfs directly from the build directory which was incomplete. When I unpack rootfs to a directory and mount that, it works, just like the instructions say.

0 Kudos
1,801 Views
RandyGraham
Contributor IV

unpack rootfs.tar that is .....

0 Kudos
1,801 Views
LuisCasado
NXP Employee
NXP Employee

Hello Randy,

I am booting correctly Kernel 3.6 and 3.7 with this u-boot command line:

console=ttyAMA0 root=/dev/nfs ip=dhcp nfsroot=192.168.1.50:/tftpboot/ltib,v3,tcp

I am using LTIB 10.12.01 rootfs. In my LTIB configuration:

./ltib -c

Target system configurations -> Options ->

Uncheck :

[  ] boot up with a tty and login

With this configuration I can boot with serial console.

I am pending to check these changes:

rootfs/etc/securetty" , change ttyAM0 and ttyAM1 to ttyAMA0 and ttyAMA1

and inittab:

::respawn:/sbin/getty -L ttyAMA0 115200 vt100

I hope this helps.

Best Regards,

0 Kudos