No Display on LVDS

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No Display on LVDS

1,394 Views
VinithNama
Contributor III

Hi,

     I'm working on IM8M MINI EVK Linux platform, we are working on integration of panasys LVDS display and we are using SN65DSI83 as an bridge converter.

I 'have applied below patch at the directory kernel-sourcr/.../git/drivers/gpu/drm/bridge.

and i have updated in my device tree file build/tmp/work-shared/imx8qmevk/kernel-source/arch/arm64/boot/dts/freescale/imx8mm-evk.dts as below

&lcdif{
 max-res = <1280>, <1024>;
 status = "okay";
};
 
&mipi_dsi {
       status = "okay";
 
        port@1 {
                dsim_to_sn65dsi8: endpoint {
                        remote-endpoint = <&sn65dsi83_in>;
                };
       };
};
 
&i2c2 {
    clock-frequency = <100000>;
    pinctrl-names = "default";
    status = "okay";
 
    lvds_bridge: sn65dsi83@2c {
        compatible = "ti,sn65dsi83";
       reg = <0x2c>;
        ti,dsi-lanes = <4>;
        ti,lvds-format = <2>;
        ti,lvds-bpp = <24>;
        ti,width-mm = <376>;
        ti,height-mm = <301>;
 
        enable-gpios = <&gpio1 14  GPIO_ACTIVE_HIGH>;
        pinctrl-names = "default";
        pinctrl-0 = <&pinctrl_dsi_lvds_bridge>;
        status = "okay";
 
       display-timings {
            lvds {
/*
                clock-frequency = <90000000>;
               hactive = <1280>;
                hsync-len = <54>;
                hback-porch = <75>;
                hfront-porch = <75>;
                vactive = <1024>;
                vsync-len = <10>;
                vback-porch = <10>;
                vfront-porch = <22>;
 
                vsync-active = <0>;
                hsync-active =<0>;
                de-active =<0>;
                pixelclk-active =<0>;
*/
                         clock-frequency = <108000000>;
                         hactive = <1280>;
                         hsync-len = <28>;
                         hback-porch = <200>;
                         hfront-porch = <180>;
                         vactive = <1023>;
                         vsync-len = <7>;
                         vback-porch = <30>;
                         vfront-porch = <5>;
 
                         vsync-active = <0>;
                         hsync-active =<0>;
                         de-active =<0>;
                         pixelclk-active =<0>;
 
           };
        };
 
        port {
           sn65dsi83_in: endpoint {
                remote-endpoint = <&dsim_to_sn65dsi8>;
           };
        };
    };
 
};
after compiling and deploying the kernel using 

bitbake -c compile -f linux-imx and bitbake -c deploy -f linux-imx then I have built entire image using bitbake imx-image-full. I cannot see any display on the LVDS ,can you help me where i was struck.

 
0 Kudos
Reply
4 Replies

1,381 Views
Zhiming_Liu
NXP TechSupport
NXP TechSupport

Hi @VinithNama 

 

PLS share your log

0 Kudos
Reply

1,377 Views
VinithNama
Contributor III

Hi Sir,

           Below image shows the log of my uboot.

 

0 Kudos
Reply

1,372 Views
Zhiming_Liu
NXP TechSupport
NXP TechSupport

Hi @VinithNama 

 

Can you confirm that your hardware is working fine?

Try to use Oscilloscope capture the i2c wave.

0 Kudos
Reply

1,285 Views
VinithNama
Contributor III

Hi Sir,

 I can able to read the i2c registers and I'm getting the reset value my i2c is working but I'm not able to get any signal in oscilloscope.

0 Kudos
Reply