New i.MX RT 1064 project using mcuxpresso IDE failure(s)

cancel
Showing results for 
Search instead for 
Did you mean: 

New i.MX RT 1064 project using mcuxpresso IDE failure(s)

81 Views
Contributor IV

Hello,

I would like to report that upon the creation of a new project for the MIMXRT1064-EVK using mcuxpresso the flash driver (under "MCU settings") is not filled in (should be MIMXRT1064.cfx).

In addition, starting the debugger, I get this error message:

"GDB stub (crt_emu_cm_redlink) terminating - GDB protocol problem: Pipe has been closed by GDB."

Again - I use all the default settings except the correction for the flash driver.

Can someone please tell me what the problem is? Sample projects can be debugged without issues.

Thanks in advance!

3 Replies

6 Views
NXP TechSupport
NXP TechSupport

Hello, Tamir Michael

You are right, when you create a new project, the flash driver (under "MCU settings") is not filled in, thanks for catching this! I already reported it with the corresponding team.

Regarding the problem you are facing when trying to debug, I couldn't reproduce this on my side. I was able to debug a new project with the default settings without problems. I used the RT1064-EVK, MCUXpresso IDE v11.0.1 and SDK v2.6.1, what tools are you using when you face this problem?

Regards, 

Victor  

0 Kudos

6 Views
Contributor IV

Hi,

Thanks for your reply - glad I could help.

I am using the standard tools provided by NXP. In the end, I just copied an example project and changed it to fit my needs as a basis for future developments (I can debug that one without issues). I still have no idea what went wrong...

0 Kudos

6 Views
NXP TechSupport
NXP TechSupport

Hello, Tamir Michael

The SDK team just confirmed that in the next revision of the SDK the behavior you reported will be fixed (flash driver (under "MCU settings") is not filled in when creating a new project).

I'm glad to hear that you were able to continue working. In the future, if you can reproduce the behavior again, let me know the steps I need to follow to reproduce it on my side and see what is causing this.  

Regards, 

Victor 

0 Kudos