Navigationbar not display well on hdmi, when lvds+hdmi dual display.

cancel
Showing results for 
Search instead for 
Did you mean: 

Navigationbar not display well on hdmi, when lvds+hdmi dual display.

604 Views
conteczxy
Contributor III

I am working with imx6q, in android 4.4 and kernel 3.0.35.

I want to make both lvds and hdmi display same, and lvds as primary, while hdmi as secondary.

So I set bootargs,

"console=ttymxc0,115200 androidboot.console=ttymxc0 vmalloc=400M init=/init video=mxcfb0:dev=ldb,LDB-1024x600,if=RGB666,bpp=32  video=mxcfb1:dev=hdmi,1920x1080M@60,if=RGB24,bpp=32  video=mxcfb2:off fbmem=10M,28M androidboot.hardware=freescale "

when android boots up,

lvds display well, it is like this,

lvds.JPG

however, hdmi display not well, the buttons under the screen are not displayed, I circled them in red.

hdmi.JPG

what is the problem, my lvds's resolution is 1024x600, and hdmi resolution is 1920x1080.

If I config hdmi as primary, and lvds as secondary,

I set bootargs,

"console=ttymxc0,115200 androidboot.console=ttymxc0 vmalloc=400M init=/init video=mxcfb1:dev=ldb,LDB-1024x600,if=RGB666,bpp=32  video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24,bpp=32  video=mxcfb2:off fbmem=10M,28M androidboot.hardware=freescale "

results are as follows.

lvds screen: no buttons on the bottom of the screen.

lvds.JPG

hdmi screen, ui seems good.

hdmi.JPG

Anyone knows something about it ? Any suggestion is appreciated.

Thanks,

Labels (1)
0 Kudos
2 Replies

58 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Xiyuan

one can try to test this case with Sabre board, please refer to attached

document sect.3.4.3 Booting with dual displays: LVDS and HDMI displays,

then port lvds for custom resolution.

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos

58 Views
conteczxy
Contributor III

I tried and tested as the document 《Android_Quick_Start_Guide.pdf》 sect 3.4.3 said, and the result is the same.

I think it may be a bug for android , and I have not found the solution for it.

0 Kudos