MfgTool2 does not see my board IMXRT1064

cancel
Showing results for 
Search instead for 
Did you mean: 

MfgTool2 does not see my board IMXRT1064

Jump to solution
32 Views
Contributor II

I am beginner, I know..

I set the i.MX RT1064 evk board in serial flash mode (01b) and I successfully executed these commands  as described in the documentation AN12238.pdf:

  • \Flashloader_RT1064_1.0_GA\Tools\sdphost\win>sdphost.exe -p COM5 -- write-file 0x20000000  Flashloader_RT1064_1.0_GA\Tools\mfgtools-rel\Profiles\MXRT106X\OS Firmware\ivt_flashloader.bin"
  • \Flashloader_RT1064_1.0_GA\Tools\sdphost\win>sdphost.exe -p COM5 -- error-status
  • \Flashloader_RT1064_1.0_GA\Tools\sdphost\win>sdphost.exe -p COM5 -- jump-address 0x20000400
  • Flashloader_RT1064_1.0_GA\Tools\blhost\win>blhost.exe -p COM5 -- get-property 1

After that I tried MfgTool2.exe. But it does not see my board. 

I did not program the eFuses yet. I understand I do not need them as long as I use serial flash mode (01b). I am a bit afraid to do this already since I can only do it ones..

 

0 Kudos
1 Solution
21 Views
NXP TechSupport
NXP TechSupport

@ruudmeer 

  Use USB OTG connector, but not the Debug USB one, and not the host USB connector.
(There are three USB connectors on the board.)  The Debug USB may be used for power supply,
or use wall power adapter (configure the board properly for it).

View solution in original post

3 Replies
22 Views
Contributor II

Thank you, but here still nothing in MfgTool:

  • Did you use MfgTool2.exe it without programming any efuses?
  • Did you use serial downloader mode (01b) ?
  • Is there any change in the default jumper settings? (On J1 I only have a connection between 5 and 6)

In case I just connect the evk board with the USB cable (on the Debug USB) and then start MfgTool2.exe I see that the tool does not see the board.

(Note: when I connect the evk board I do get a drive with the two files DETAILS.TXT and PRODINFO.HTM)

 

This is what I find in MfgTool.log:

DLL version: 2.7.0
Wednesday, September 09, 2020 11:12:20 Start new logging
ModuleID[2] LevelID[10]: CMyExceptionHandler thread is running
ModuleID[2] LevelID[1]: new MxHidDeviceClass
ModuleID[2] LevelID[1]: new KBLHidDeviceClass
ModuleID[2] LevelID[10]: Device Manager thread is running
ModuleID[2] LevelID[1]: Can't set m_hStopEvent before it initialized or it already stop

ModuleID[2] LevelID[10]: CCmdOpreation[0] thread is Closed
ModuleID[2] LevelID[10]: CCmdOpreation[0] thread is Closed
ModuleID[2] LevelID[10]: DeviceManager::OnMsgDeviceEvent() - EVENT_KILL
ModuleID[2] LevelID[10]: CMyExceptionHandler::OnMsgExceptionEvent() - KillExceptionHandlerThread
ModuleID[2] LevelID[10]: Exception Handler thread is closed
ModuleID[2] LevelID[1]: delete MxHidDeviceClass
ModuleID[2] LevelID[1]: delete MxHidDeviceClass
ModuleID[2] LevelID[10]: Device Manager thread is closed

 

0 Kudos
22 Views
NXP TechSupport
NXP TechSupport

@ruudmeer 

  Use USB OTG connector, but not the Debug USB one, and not the host USB connector.
(There are three USB connectors on the board.)  The Debug USB may be used for power supply,
or use wall power adapter (configure the board properly for it).

View solution in original post

26 Views
NXP TechSupport
NXP TechSupport

@ruudmeer 

Hello,

   just tried the 1064 EVK with the MFG - it works.
Use USB OTG connector for the MFG.

https://www.nxp.com/webapp/sps/download/license.jsp?colCode=FLASHLOADER-RT1064-1.0

 

Regards,
Yuri.

 

0 Kudos