Memory edit leads to debug break at 0xdeadbeee

cancel
Showing results for 
Search instead for 
Did you mean: 

Memory edit leads to debug break at 0xdeadbeee

Jump to solution
190 Views
petrama
Contributor III

Using MCUXpresso memory map editor editing memory map for "Hello World" from EVK RT1024-SDK  results in this message when executing Debug:

"Break at address "0xdeadbeee" with no debug information available, or outside of program code."

The memory change is size of SRAM_OC changed from 0x20000 to 0x10000 and SRAM_ITC size changed from 0x10000 to 0x20000. So 0x10000KB is moved from SRAM_OC to SRAM_ITC.

petrama_0-1658759721461.png

(Later note:I think an error here is that BOARD_SDRAM and NCACHE:REGION should be placed last, so that SRAM_DTC is the first RAM block.)

What am I missing - is there someting else I need to do? (all breakpoints have been removed)

In the editor all that is required is to change the memory block sizes by portions of 32KB - no other fields?

What purpose does the checkbox "Preserve memory configuration" have?

Tags (1)
0 Kudos
1 Solution
182 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi @petrama ,

  Please check this application note at first:

https://www.nxp.com.cn/docs/en/application-note/AN12077.pdf

kerryzhou_0-1658825102597.png

 

You can see, the FlexRAM default  OCRAM is 128KB, DTCM is 64 KB , ITCM is 64KB.

So, if you want to use larger ITCM to 128KB, OCRAM to 64KB, you need to do the flexRAM reconfiguration.

kerryzhou_1-1658825249693.png

Otherwise, it will have issues.

https://community.nxp.com/t5/i-MX-RT-Knowledge-Base/Reallocating-the-FlexRAM/ta-p/1117649

The above post for flexRAM reallocate also useful to you.

Best Regards,

Kerry

 

View solution in original post

1 Reply
183 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi @petrama ,

  Please check this application note at first:

https://www.nxp.com.cn/docs/en/application-note/AN12077.pdf

kerryzhou_0-1658825102597.png

 

You can see, the FlexRAM default  OCRAM is 128KB, DTCM is 64 KB , ITCM is 64KB.

So, if you want to use larger ITCM to 128KB, OCRAM to 64KB, you need to do the flexRAM reconfiguration.

kerryzhou_1-1658825249693.png

Otherwise, it will have issues.

https://community.nxp.com/t5/i-MX-RT-Knowledge-Base/Reallocating-the-FlexRAM/ta-p/1117649

The above post for flexRAM reallocate also useful to you.

Best Regards,

Kerry