[MX8-DSI-OLED1] Display aspect ratio is wrong

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

[MX8-DSI-OLED1] Display aspect ratio is wrong

Jump to solution
1,625 Views
Takashi_Kashiwagi
Senior Contributor I

Hi everyone.

I have using "MIMX8MQ-EVK" with "fsl-image-qt5-validation-imx".

When I used HDMI, The aspect ratio was normal.

But when using MX8 - DSI - OLED 1, the aspect ratio was wrong as below.

Q. How can I adjust the aspect ratio?

IMG_3764.JPG

I used "fsl-imx8mq-evk-dcss-rm67191.dtb" and I modified "/etc/xdg/weston/weston.ini".

I can rotate the window, but aspect ratio is still wrong.

Am I misunderstanding?

weston.ini is as follows.

root@imx8mqevk:/sys/class/drm/card0# more /etc/xdg/weston/weston.ini
[core]
# i.MX: Disable idle timeout
idle-time=0
#use-g2d=1
gbm-format=argb8888
[libinput]
touchscreen_calibrator=true
[output]
name=DSI-1
mode=1920x1080@60 16:9
#mode=1080x1920@60
transform=90
[shell]
size=1920x1080
#[output]
#name=HDMI-A-2
#mode=off
#       WIDTHxHEIGHT    Resolution size width and height in pixels
#       off             Disables the output
#       preferred       Uses the preferred mode
#       current         Uses the current crt controller mode
#transform=90

Best Regards,

T.Kashiwagi

Tags (1)
1 Solution
1,297 Views
Takashi_Kashiwagi
Senior Contributor I

Hi Joan

Thank you for responding!

JUST NOW, I was able to solve the problem using the following weston.ini

Apparently, if I declare the output section and the shell section at the same time, the aspect ratio becames to be wrong.

root@imx8mqevk:~# more /etc/xdg/weston/weston.ini
[core]
# i.MX: Disable idle timeout
idle-time=0
#use-g2d=1
gbm-format=argb8888
[libinput]
touchscreen_calibrator=true
[output]
name=DSI-1
mode=1920x1080@60 16:9
#mode=1080x1920@60
transform=90
#[shell]
#size=1920x1080
#[output]
#name=HDMI-A-2
#mode=off
#       WIDTHxHEIGHT    Resolution size width and height in pixels
#       off             Disables the output
#       preferred       Uses the preferred mode
#       current         Uses the current crt controller mode
#transform=90
[screen-share]
command=/usr/bin/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --n
o-clients-resize
root@imx8mqevk:~#

enabe [shell] section. (The upper right time is NOT displayed.)

IMG_3767.JPG

disable [shell] section. (The upper right time is displayed.)

IMG_3768.JPG

Best Regards,

T.Kashiwagi

View solution in original post

0 Kudos
Reply
2 Replies
1,297 Views
joanxie
NXP TechSupport
NXP TechSupport

I tested the OLED, didn't find any aspect ratio issue, if you don't change westion, still has this issue?pls check the uboot command, you can change the uboot command to get the correct aspect ration you want to get

1,298 Views
Takashi_Kashiwagi
Senior Contributor I

Hi Joan

Thank you for responding!

JUST NOW, I was able to solve the problem using the following weston.ini

Apparently, if I declare the output section and the shell section at the same time, the aspect ratio becames to be wrong.

root@imx8mqevk:~# more /etc/xdg/weston/weston.ini
[core]
# i.MX: Disable idle timeout
idle-time=0
#use-g2d=1
gbm-format=argb8888
[libinput]
touchscreen_calibrator=true
[output]
name=DSI-1
mode=1920x1080@60 16:9
#mode=1080x1920@60
transform=90
#[shell]
#size=1920x1080
#[output]
#name=HDMI-A-2
#mode=off
#       WIDTHxHEIGHT    Resolution size width and height in pixels
#       off             Disables the output
#       preferred       Uses the preferred mode
#       current         Uses the current crt controller mode
#transform=90
[screen-share]
command=/usr/bin/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --n
o-clients-resize
root@imx8mqevk:~#

enabe [shell] section. (The upper right time is NOT displayed.)

IMG_3767.JPG

disable [shell] section. (The upper right time is displayed.)

IMG_3768.JPG

Best Regards,

T.Kashiwagi

0 Kudos
Reply