MX28 - Bootlets running but failing at u-boot/Linux

cancel
Showing results for 
Search instead for 
Did you mean: 

MX28 - Bootlets running but failing at u-boot/Linux

430 Views
bchapp
Contributor I

Our EVK is properly booting a fresh rebuild of imx28_ivt_linux.sb and imx28_ivt_uboot.sb.  On our prototype, we see the bootlets execute properly but end up with a crash just before u-boot or Linux begin execution.  Our output is below.

HTLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLFLC

PowerPrep start initialize power...

Battery Voltage = 0.53V

No battery or bad battery detected!!!.

Disabling battery voltage measurements.

LLLCSep 10 201012:30:50

FRAC 0x92925552

Wait for ddr ready 1power 0x00820616

Frac 0x92925552

start change cpu freq

hbus 0x00000003

cpu 0x00010001

start test memory accress

ddr2 0x40000000

finish simple test

LLLLLLLFLCLLJ

Undefined Ins

The system reboots after the Undefined Ins output.

Has anyone ever seen this error?  We have only found one other reference to this error, and it was due to a memory issue.  We defined MEMORY_TEST in the bootlet as suggested by that thread, but all appears to be well.  Neither the uboot or linux images will boot on our board, but they function fine on the EVK.  We cannot even find out what code is spitting out the error. 

Any help is appreciated!

Labels (1)
0 Kudos
3 Replies

18 Views
YixingKong
Senior Contributor IV

Brian

This discussion is closed since no activity. If you still need help, please feel free to reply with an update to this

discussion, or create another discussion.
Thanks,
Yixing

0 Kudos

18 Views
YixingKong
Senior Contributor IV

Brian

Had your issue got resolved? If yes, we are going to close the discussion in 3 days. If you still need help please feel

free to contact Freescale.

Thanks,
Yixing

0 Kudos

18 Views
Yuri
NXP TechSupport
NXP TechSupport

I am afraid simple memory test in the bootlet does not provide comprehensive testing.

0 Kudos