MIMXRT1170 EVK JTAG connection with IAR i-jet

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MIMXRT1170 EVK JTAG connection with IAR i-jet

Jump to solution
367 Views
GLantzTCore
Contributor III

I am having trouble getting the IAR i-jet probe to connect to the EVK.  We have looked at the User's Guide and identified the Rxxx s that need to be removed except for R78 which on the C4 board appears to be an ethernet reset line and not related to anything JTAG.  

Are there jumpers that need to be eliminated/connected?  Pull up resisters that need to be added?

 

0 Kudos
1 Solution
326 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi @GLantzTCore ,

   Please refer to this information if you want to use the external JTAG, I mean, JTAG, not SWD:

kerryzhou_0-1711359859537.png

Then, also remove the J5,J6,J7,J8

kerryzhou_1-1711359889688.png

After this, you can use the external debugger with JTAG, if you just need to use the SWD, you don't need to remove the resistor, just remove the J5-J8.

 

Wish it helps you!

If you still have question about it, please kindly let me know.

If your question is solved, please help me to mark the correct answer, just to close this case, thanks.

Any new issues, welcome to create the new question post.

Best Regards,

Kerry

 

 

View solution in original post

0 Kudos
3 Replies
327 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi @GLantzTCore ,

   Please refer to this information if you want to use the external JTAG, I mean, JTAG, not SWD:

kerryzhou_0-1711359859537.png

Then, also remove the J5,J6,J7,J8

kerryzhou_1-1711359889688.png

After this, you can use the external debugger with JTAG, if you just need to use the SWD, you don't need to remove the resistor, just remove the J5-J8.

 

Wish it helps you!

If you still have question about it, please kindly let me know.

If your question is solved, please help me to mark the correct answer, just to close this case, thanks.

Any new issues, welcome to create the new question post.

Best Regards,

Kerry

 

 

0 Kudos
319 Views
GLantzTCore
Contributor III

Removing the resistors and jumpers resolved the issue.  It does appear that the USB port becomes disabled with removing those parts.

314 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Good!

If you meet any issues in the future, welcome to create the new question post to discuss it, thanks.

 

Best Regards,

Kerry

0 Kudos