MCIMX7Sabre board blank screen

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MCIMX7Sabre board blank screen

Jump to solution
1,052 Views
jeffhubeny
Contributor II

I have an MCIMX7SABRE board. I inserted the sd card that came with it and powered it on. A monitor is plugged into the HDMI port and I can see the monitor signal light is lit, but the screen is black.The green power led is lit. The yellow led next to the ethernet port is lit, but I get nothing on the screen. I tried a different monitor, but still nothing. I tried plugging in a windows laptop with putty to the debug port. The two ports show up in device manager as COM3/COM4, but when I set putty to COM3 with 115200-8n1 and click open I get nothing. I checked the SD card to see if it really contains an OS and it does.

Is the board bad, or is there something I've overlooked?

Labels (1)
1 Solution
921 Views
jeffhubeny
Contributor II

Just to close the loop, using a different sd card image resolved my problem. Now both the serial port and the hdmi screen work. This issue is resolved. Thanks for your help.

View solution in original post

5 Replies
921 Views
Rita_Wang
NXP TechSupport
NXP TechSupport

Hi,

Could you tell me which version BSP are you using?
Have a great day,
Rita

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
921 Views
Rita_Wang
NXP TechSupport
NXP TechSupport

Hi,

You need to set the "video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24" for an HDMI display when the u-boot boot up in the command line.
Have a great day,
Rita

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
921 Views
marius_grigoras
NXP Employee
NXP Employee

And make sure your monitor is with HDMI cable and not with a vga-to-hdmi adaptor (the low-level display driver will not work).

0 Kudos
921 Views
jeffhubeny
Contributor II

I don't get any u-boot command line to type on. The debug serial port shows up in device manager, but putty won't connect to it, so I can't get to anything that lets me enter the video options.

I tried a third newer monitor that definitely supports 1920x1080, but no luck. It's hdmi to dvi, but no vga converters involved. I tested the hdmi-dvi cable with a laptop that has Linux on it just to make sure it's ok.

The image I'm trying to boot came with the board. It's labeled "MCIMX7SABRE Linux L4.1.15_1.2.0 GA 110-78016X"

Thanks for your help. Someone with the same board is going to ftp a Linux image to me. I'm going to try their image too.

0 Kudos
922 Views
jeffhubeny
Contributor II

Just to close the loop, using a different sd card image resolved my problem. Now both the serial port and the hdmi screen work. This issue is resolved. Thanks for your help.