M4 wakeup A53 in I.MX8MM EVK on Linux 5.4.24

cancel
Showing results for 
Search instead for 
Did you mean: 

M4 wakeup A53 in I.MX8MM EVK on Linux 5.4.24

Jump to solution
111 Views
Contributor I

On my Linux 5.4.24 build i have applied 0001-atf-m4-run-for-5.4.24-kernel.patch and 0001-iMX8MM-GIR-wakeup-for-5.4.24-kernel.patch from this post,

https://community.nxp.com/t5/i-MX-Processors-Knowledge-Base/M4-Low-Power-Demo-on-i-MX8MM/ta-p/110110...

After the A53 is suspended and waken up from M4 using freertos_hello.bin by MU GIR INT for the first time, when the A53 is suspended for the second time it immediately wakes up from suspend without waiting for any new interrupt from M4.

Any help to fix this is appreciated.

Labels (1)
0 Kudos
1 Solution
71 Views
Contributor I

On debugging found GIR wakeup irq status was not being cleared.

 

Setting this env in uboot seemed to fix the imx MU issues for kernel 5.4.24

setenv fdt_file 'imx8mm-evk-rpmsg.dtb'

View solution in original post

0 Kudos
2 Replies
72 Views
Contributor I

On debugging found GIR wakeup irq status was not being cleared.

 

Setting this env in uboot seemed to fix the imx MU issues for kernel 5.4.24

setenv fdt_file 'imx8mm-evk-rpmsg.dtb'

View solution in original post

0 Kudos
87 Views
Contributor II

check wakeup sources, if SNVS RTC wakeup is enabled, then disable it

# find wakeup enabled devices
$ find /sys/devices/ -name wakeup -exec grep enabled -H {} \;

0 Kudos