Ltib and Qt Embedded Issue on iMX53

cancel
Showing results for 
Search instead for 
Did you mean: 

Ltib and Qt Embedded Issue on iMX53

983 Views
GiovanniFoiani
Contributor I

Hi all,

I'm trying to build ltib distribution (kernel-2.6.35.3-imx_11.09.01) with Qt Embedded support.

I added the following packages in Ltib configuration:

amd-gpu-bin-mx51 
libz160-bin 
fsl-mm-codec-libs
gstreamer-fsl-plugins
fontconfig
freetype
gstreamer
gstreamer-plugins-base
gstreamer-plugins-good
gstreamer-plugins-bad
gstreamer-plugins-ugly
Liberation fonts
libjpeg
libpng
liboil
libxml2
mysql
Qt Embedded
Phonon
zlib

but when I try to build I get the following error:

/usr/lib/i386-linux-gnu/libfreetype.so: could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[3]: *** [libfontconfig.la] Error 1
make[3]: Leaving directory `/home/gfoiani/ltib/rpm/BUILD/fontconfig-2.4.2/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/gfoiani/ltib/rpm/BUILD/fontconfig-2.4.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/gfoiani/ltib/rpm/BUILD/fontconfig-2.4.2'
make: *** [all] Error 2
error: Bad exit status from /home/gfoiani/ltib/tmp/rpm-tmp.63651 (%build)


RPM build errors:
    Bad exit status from /home/gfoiani/ltib/tmp/rpm-tmp.63651 (%build)
Build time for fontconfig: 11 seconds

Failed building fontconfig


f_buildrpms() returned an error, exiting
traceback:
 main:560


Started: Thu Apr 12 11:31:17 2012
Ended:   Thu Apr 12 11:32:24 2012
Elapsed: 67 seconds

These packages failed to build:
fontconfig 

Build Failed

Exiting on error or interrupt


Any advice?
Do I have to build Qt outside Ltib?

Thanks 

Giovanni
Labels (1)
0 Kudos
3 Replies

277 Views
PaulRobertson
Contributor I

The link referenced above by Remi looks very good and I believe I will be referring to it in the near future.  However, The fontconfig issue is one of the first I have learned to deal with when using ltib to build packages for the QSB. So, if you don't want to "start over" but would rather just press forward, you start with the following.

The fontconfig problem boils down to the build process trying to link in the freetype shared library that was built for the build machine (most likely an Intel-based PC) instead of the library that was cross-compiled for the target (an ARM-based board -- the QSB).  You will need to edit the ltib  fontconfig.spec file to direct the ./configure script to use the correct freetype library.

The fontconfig.spec is located in a subdirectory under you ltib directory :

                                      dist/lfs-5.1/fontconfig/fontconfig.spec

In said .spec file, you will need to modify the line which calls ./configure to add this:

                                    --with-freetype-config="$DEV_IMAGE/usr/bin/freetype-config --prefix=$DEV_IMAGE/usr"

For more info, google the problem and look for a solution described by a user called "frogman."  Or, check out http://forums.freescale.com/t5/i-MX-Microprocessors/Ltib-link-error-with-fontconfig-on-Ubuntu-host/m...

0 Kudos

277 Views
rlorriaux
Contributor I

Hi Giovanni,

You will have to build it outside of LTIB. This will provide the added benefit of providing you a more recent version. See http://imxcommunity.org/group/imxqt/forum/topics/building-qt-for-imx5x?xg_source=activity

0 Kudos

277 Views
dougschwanke
Contributor IV

The above link is broken.  Is there a new link available?

0 Kudos