Latest versions of Ubuntu and/or Fedora that are guaranteed/known to work with LTIB 9.1.1

cancel
Showing results for 
Search instead for 
Did you mean: 

Latest versions of Ubuntu and/or Fedora that are guaranteed/known to work with LTIB 9.1.1

393 Views
AdCmo
Contributor III

All,


Can someone please list the latest versions of Ubuntu and/or Fedora
that are guaranteed/known to work with LTIB 9.1.1 on i.MX53 at least?

So far I am having LTIB fail on Ubuntu 11.10.

I ran:

./ltib -m config

All the following build OK:

Processing: rpm-fs
Processing: fake-provide
Processing: mkspooflinks
Processing: distcc     
Processing: ccache     
Processing: bison      
Processing: flex       
Processing: texinfo    
Processing: autoconf   
Processing: libtool    
...

LTIB breaks at lkc with this error:

...

Processing: lkc
=================

....

util.c:(.text+0xa58): undefined reference to `winch'
util.c:(.text+0xa6c): undefined reference to `waddch'
util.c:(.text+0xa8b): undefined reference to `wnoutrefresh'
collect2: ld returned 1 exit status
make: *** [mconf] Error 1
error: Bad exit status from /opt/freescale/ltib/tmp/rpm-tmp.33058 (%build)


RPM build errors:
    Bad exit status from /opt/freescale/ltib/tmp/rpm-tmp.33058 (%build)
Build time for lkc: 2 seconds

Failed building lkc
Died at ./ltib line 1380.
traceback:
 main::build_host_rpms:1380
  main::host_checks:1435
   main:542

-------------------------------------------------------------------------------------------------------

 

I read somwere that it might be because of ncurses.

I installed "libncursesw5-dev" which was picked instead of "libncurses-dev"
and "ncurses-dev" which I tried.

 

Any clues what I am missing?

"/opt/freescale/ltib/tmp/rpm-tmp.33058" is attached:

 

Thanks,

Ad.

----------------------------

Original Attachment has been moved to: 515-optfreescaleltibtmprpmtmp.33058

Labels (1)
0 Kudos
3 Replies

88 Views
AdCmo
Contributor III

Follow this thread.

http://imxcommunity.org/group/imx53quickstartboard/forum/topics/ubuntu-11-10-oneiric-64-bit-virtual-...

And workarounds here:

http://vijay496.blogspot.com/2012/03/ltib-for-ubuntu-1110-error-fac...

I am running Ubuntu 11.10 32-bit but my team members were successful on 12.04 as well.


Ad.
-----------------

0 Kudos

88 Views
EdSutter
Senior Contributor II

Hmmm...

I think I see the problem.  In my case, the log shows me a gcc line like this:

gcc -lncurses mconf.o zconf.tab.o lxdialog/lxdialog.a -o mconf

right above that the log shows that lxdialog.a includes the curses stuff

IIRC, the placement of -lncurses at the beginning of the gcc line is just wrong.  It should be

placed AFTER lxdialog/lxdialog.a so that the curses stuff needed by lxdialog.a is pulled in.

Not sure how to fix this cause after this dies, if you modify the makefile to fix the error, LTIB just overwrites the makefile.

0 Kudos

88 Views
EdSutter
Senior Contributor II

Ad,

Did you ever resolve this?  I'm trying to build with an even newer version of UBUNTU and I ran into a similar problem.  Kinda strange too, 'cause the linkage that causes the load of "undefined reference" errors attempts to pull in the ncurses.a library, and I did an 'nm' on that library and those functions are there as expected, so I really don't understand why this error is even occurring.

Ed

0 Kudos